Bug 211842 - mail/p5-Mail-DKIM: Missing dependency
Summary: mail/p5-Mail-DKIM: Missing dependency
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-perl (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-14 18:05 UTC by Max Kostikov
Modified: 2016-08-14 18:58 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (perl)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Kostikov 2016-08-14 18:05:16 UTC
I found that mail/p5-Mail-DKIM port doesn't works becаuse missing dependency to Crypt::OpenSSL::RSA module

авг 14 19:55:59.319 [29569] dbg: dkim: cannot load Mail::DKIM module, DKIM checks disabled: Can't locate Crypt/OpenSSL/RSA.pm in @INC (you may need to install the Crypt::OpenSSL::RSA module) (@INC contains: /var/db/spamassassin/compiled/5.020/3.004001 /var/db/spamassassin/compiled/5.020/3.004001/auto lib /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/site_perl/mach/5.20 /usr/local/lib/perl5/5.20/mach /usr/local/lib/perl5/5.20 /usr/local/lib/perl5/site_perl/5.20 /usr/local/lib/perl5/site_perl/5.20/mach) at /usr/local/lib/perl5/site_perl/Mail/DKIM/PublicKey.pm line 333.
авг 14 19:55:59.319 [29569] dbg: dkim: [...] BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/Mail/DKIM/PublicKey.pm line 333.
авг 14 19:55:59.320 [29569] dbg: dkim: [...] Compilation failed in require at /usr/local/lib/perl5/site_perl/Mail/DKIM/Signature.pm line 13.
авг 14 19:55:59.320 [29569] dbg: dkim: [...] BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/Mail/DKIM/Signature.pm line 13.
авг 14 19:55:59.320 [29569] dbg: dkim: [...] Compilation failed in require at /usr/local/lib/perl5/site_perl/Mail/DKIM/Verifier.pm line 13.
авг 14 19:55:59.320 [29569] dbg: dkim: [...] BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/Mail/DKIM/Verifier.pm line 13.
авг 14 19:55:59.320 [29569] dbg: dkim: [...] Compilation failed in require at /usr/local/lib/perl5/site_perl/Mail/SpamAssassin/Plugin/DKIM.pm line 648.
Comment 1 Kurt Jaeger freebsd_committer 2016-08-14 18:25:36 UTC
Please note that BUILD- and RUN_DEPENDS has security/p5-Crypt-OpenSSL-RSA
listed as dependency, so if it is missing, maybe it's missing only in your installation ?

What does 

portfind p5-Crypt-OpenSSL-RSA

or pkg info | grep -i Crypt-OpenSSL say ? (portfind is from ports-mgmt/portfind).
Comment 2 Max Kostikov 2016-08-14 18:35:00 UTC
# pkg info | grep p5-Crypt-OpenSSL-RSA
p5-Crypt-OpenSSL-RSA-0.28_1    Perl5 module to RSA encode and decode strings using OpenSSL

At this moment as temporary solution I installed Crypt::OpenSSL::RSA via CPAN manually and all works as it must. I think this is problem with pathes in module @INC - they are doesn't points to p5-Crypt-OpenSSL-RSA installed file.
Comment 3 Kurt Jaeger freebsd_committer 2016-08-14 18:40:11 UTC
Do you have a testcase -- how do you call Mail::DKIM ?
Comment 4 Max Kostikov 2016-08-14 18:46:14 UTC
(In reply to Kurt Jaeger from comment #3)
From Spamassassin module. Quoted log taken from 'spamassassin -D' output.
Comment 5 Max Kostikov 2016-08-14 18:55:06 UTC
I think I found problem.
By default FreeBSD using Perl 5.20 at this moment.
But I have (and have no clue why) p5-Crypt-OpenSSL-RSA installed in Perl 5.18 directories

# pkg info -l p5-Crypt-OpenSSL-RSA
p5-Crypt-OpenSSL-RSA-0.28_1:
        /usr/local/lib/perl5/site_perl/mach/5.18/Crypt/OpenSSL/RSA.pm
        /usr/local/lib/perl5/site_perl/mach/5.18/auto/Crypt/OpenSSL/RSA/RSA.so
        /usr/local/lib/perl5/site_perl/mach/5.18/auto/Crypt/OpenSSL/RSA/autosplit.ix
        /usr/local/lib/perl5/site_perl/mach/5.18/auto/Crypt/OpenSSL/RSA/get_key_parameters.al
        /usr/local/lib/perl5/site_perl/mach/5.18/auto/Crypt/OpenSSL/RSA/import_random_seed.al
        /usr/local/lib/perl5/site_perl/mach/5.18/auto/Crypt/OpenSSL/RSA/new_key_from_parameters.al
        /usr/local/lib/perl5/site_perl/mach/5.18/auto/Crypt/OpenSSL/RSA/new_public_key.al
        /usr/local/lib/perl5/site_perl/man/man3/Crypt::OpenSSL::RSA.3.gz

So after pkg delete -fy p5-Crypt-OpenSSL-RSA &&  pkg install p5-Crypt-OpenSSL-RSA all was reinstalled in 5.20 directories.
So this is not port bug but local installation issue.
Thank you for support!
Comment 6 Kurt Jaeger freebsd_committer 2016-08-14 18:58:42 UTC
Thanks for the heads-up about the cause, closing the ticket.