Bug 211843 - devel/libnfc: needs USES+=readline
Summary: devel/libnfc: needs USES+=readline
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Romain Tartière
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-14 19:48 UTC by Kurt Jaeger
Modified: 2016-10-15 07:02 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (romain)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2016-08-14 19:48:55 UTC
Testbuilding caused the build to fail with missing readline. Can you add it to the USES ?

This is the error:

  CCLD   nfc-dep-target
pn53x-tamashell.c:48:12: fatal error: 'readline/readline.h' file not found
#  include <readline/readline.h>
Comment 1 Romain Tartière freebsd_committer 2016-08-14 20:51:23 UTC
Hello!

I can't reproduce the failure (it compiles successfully in poudriere with 9.3-RELEASE amd64, 10.1-RELEASE amd64, 10.1-RELEASE i386, 10.2-RELEASE amd64, 10.3-RELEASE amd64), can you please tell me how to reproduce this so that I can avoid this problem in the future?

Thanks!
Comment 2 Kurt Jaeger freebsd_committer 2016-08-14 20:57:12 UTC
If you build it *outside* poudriere, and readline is installed, configure detects the .h file, but fails to add the proper -I options so that the build fails.
Comment 3 Romain Tartière freebsd_committer 2016-08-14 21:19:03 UTC
Hum, still can't reproduce the problem, FreeBSD 10.3-STABLE r301311, running make from the port directory in a "normal" environment (not with poudriere).

I tried to reset to the default option, same result: everything is fine. pkg report readline-6.3.8 is installed.

I must be missing something…  Any idea?
Comment 4 Romain Tartière freebsd_committer 2016-10-15 07:02:25 UTC
Fixed, thanks!
Comment 5 commit-hook freebsd_committer 2016-10-15 07:02:34 UTC
A commit references this bug:

Author: romain
Date: Sat Oct 15 07:02:05 UTC 2016
New revision: 424004
URL: https://svnweb.freebsd.org/changeset/ports/424004

Log:
  Minor updates

    1. Fix dependency on readline
    2. Set license
    3. Bump PORTVERSION

  PR:		211843 [1]
  Submitted by:	pi [1]

Changes:
  head/devel/libnfc/Makefile