Bug 211868 - FreeBSD ftp missing release files for armv6 and mips (and possibly other archs)
Summary: FreeBSD ftp missing release files for armv6 and mips (and possibly other archs)
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 11.0-RC1
Hardware: Any Any
: --- Affects Many People
Assignee: FreeBSD Release Engineering
URL:
Keywords:
: 211778 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-15 12:26 UTC by Dmitry Marakasov
Modified: 2020-10-27 15:57 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2016-08-15 12:26:28 UTC
Apart from ISO files, there are release tarballs hosted on FreeBSD ftp for each release. For example:

% curl ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/amd64/10.3-RELEASE/
-rw-r--r--    1 ftp      ftp           782 Mar 25 02:13 MANIFEST
-rw-r--r--    1 ftp      ftp      70325324 Mar 25 02:13 base.txz
-rw-r--r--    1 ftp      ftp       1432464 Mar 25 02:13 doc.txz
-rw-r--r--    1 ftp      ftp        886184 Mar 25 02:13 games.txz
-rw-r--r--    1 ftp      ftp      97807424 Mar 25 02:13 kernel.txz
-rw-r--r--    1 ftp      ftp      17545052 Mar 25 02:13 lib32.txz
-rw-r--r--    1 ftp      ftp      35045976 Mar 25 02:13 ports.txz
-rw-r--r--    1 ftp      ftp      126900216 Mar 25 02:13 src.txz

Such files however are missing for less common architectures, namely arm/armv6 and mips/mips. These are crucial for poudriere jails and manual installs and should be uploaded.
Comment 1 Glen Barber freebsd_committer 2016-08-15 20:57:28 UTC
The FreeBSD releases for arm/armv6 do not have a "bootonly" image, so producing these files does not make sense.  This has come up in the past, and at present there is no intent to provide them until we switch to pkg(8)-managed binary upgrades (which eliminates the lack of these files entirely).

Additionally, we do not build releases for mips/mips*, so this affects arm/armv6 only.
Comment 2 Dmitry Marakasov freebsd_committer 2016-08-15 21:33:34 UTC
(In reply to Glen Barber from comment #1)

> The FreeBSD releases for arm/armv6 do not have a "bootonly" image, so
> producing these files does not make sense.

How is this related? As I've mentioned these have a lot of uses, incl. creating ftp-backed poudriere jails and fast arm installs without building from source.
Comment 3 Glen Barber freebsd_committer 2016-08-15 21:37:48 UTC
The original real reason base.txz, kernel.txz, etc., existed was for bootonly.iso, which would remotely fetch the distribution to extract onto the install target disk.

Keep in mind, arm/armv6 releases are still relatively new, so this particular use case was admittedly missed.  However when we eventually switch to using pkg to manage the base system upgrade/installation path, these files (for arm/armv6) will not be needed anyway.
Comment 4 Dmitry Marakasov freebsd_committer 2016-08-16 00:02:19 UTC
(In reply to Glen Barber from comment #3)

> The original real reason base.txz, kernel.txz, etc., existed was for
> bootonly.iso, which would remotely fetch the distribution to extract onto
> the install target disk.

As mentioned, there are many more uses for these files now.

> Keep in mind, arm/armv6 releases are still relatively new, so this
> particular use case was admittedly missed.  However when we eventually
> switch to using pkg to manage the base system upgrade/installation path,
> these files (for arm/armv6) will not be needed anyway.

Packaged base is a matter of distant and uncertain future, while the need for these files is urgent. I don't see any real reasons why we can't provide releases for all architectures for 11.0.
Comment 5 Glen Barber freebsd_committer 2016-08-16 00:54:50 UTC
(In reply to Dmitry Marakasov from comment #4)
> Packaged base is a matter of distant and uncertain future, while the need
> for these files is urgent. I don't see any real reasons why we can't provide
> releases for all architectures for 11.0.

I do.  Look at the Makefile, Makefile.inc1, and release/Makefile.

None of these are arm-aware, and they will not be for 11.0-RELEASE.  You are raising this far too late in the release cycle.
Comment 6 Glen Barber freebsd_committer 2020-10-27 15:57:27 UTC
*** Bug 211778 has been marked as a duplicate of this bug. ***