Bug 211923 - www/phalcon: Update to 3.0.1 (Adds PHP 7.0 support)
Summary: www/phalcon: Update to 3.0.1 (Adds PHP 7.0 support)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Torsten Zuehlsdorff
URL:
Keywords: easy
: 211359 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-17 06:31 UTC by Franco Fichtner
Modified: 2016-09-23 09:02 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (linpct)


Attachments
0002: 3.0.0 rework (1.94 KB, patch)
2016-08-17 06:31 UTC, Franco Fichtner
linpct: maintainer-approval+
Details | Diff
PHP 5.6 testport output (25.64 KB, text/plain)
2016-08-17 12:11 UTC, Franco Fichtner
no flags Details
PHP 7.0 testport output (25.71 KB, text/plain)
2016-08-17 12:12 UTC, Franco Fichtner
no flags Details
0003: patch for 3.0.1 (1.10 KB, patch)
2016-08-25 13:10 UTC, Franco Fichtner
linpct: maintainer-approval+
Details | Diff
0001: armv6 additions (865 bytes, patch)
2016-08-25 13:14 UTC, Franco Fichtner
franco: maintainer-approval? (linpct)
Details | Diff
ARMv6 build log for Phalcon 3.0.1 on PHP 5.6 (93.62 KB, application/x-gzip)
2016-08-26 08:57 UTC, Franco Fichtner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franco Fichtner 2016-08-17 06:31:24 UTC
Created attachment 173764 [details]
0002: 3.0.0 rework

This also incorporates work from: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=211359
Comment 1 linpct 2016-08-17 11:15:47 UTC
Hi, any built log?

Thanks.
Comment 2 Franco Fichtner 2016-08-17 11:17:06 UTC
Want one for PHP 5.6 or PHP 7.0? :)

PHP 5.6 runtime test looks good so far.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-17 11:42:04 UTC
@Franco, does this obsolete bug 211359?

Please confirm successful QA on both PHP 5 and /7 please
Comment 4 Franco Fichtner 2016-08-17 12:11:59 UTC
Created attachment 173777 [details]
PHP 5.6 testport output
Comment 5 Franco Fichtner 2016-08-17 12:12:19 UTC
Created attachment 173778 [details]
PHP 7.0 testport output
Comment 6 Franco Fichtner 2016-08-17 12:29:58 UTC
Hi Kubilay,

Yes, it would obsolete the other issue.  The proposed patch adds armv6 support too.


Cheers,
Franco
Comment 7 linpct 2016-08-17 12:31:08 UTC
Comment on attachment 173764 [details]
0002: 3.0.0 rework

Maintainer approved, thanks.
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-17 12:57:32 UTC
*** Bug 211359 has been marked as a duplicate of this bug. ***
Comment 9 linpct 2016-08-25 11:40:39 UTC
Hi,

Currently 3.0.1 had released, will provide 3.0.1 patch?

Thanks.
Comment 10 Franco Fichtner 2016-08-25 11:44:25 UTC
Hi,

I can provide one today after some testing, though I'd rather wrap this up first and open a new issue?


Cheers,
Franco
Comment 11 Franco Fichtner 2016-08-25 13:10:16 UTC
Created attachment 174056 [details]
0003: patch for 3.0.1

I haven't given it the full round of testing, but unit tests and GUI rendering and API operation works within OPNsense.  Feel free to ack now or defer.
Comment 12 Franco Fichtner 2016-08-25 13:14:27 UTC
Created attachment 174057 [details]
0001: armv6 additions
Comment 13 Franco Fichtner 2016-08-25 13:15:06 UTC
In accordance with tz@, I've uploaded all the patches and marked them in their apply order as they all depend on each other.
Comment 14 linpct 2016-08-26 04:40:07 UTC
Comment on attachment 174056 [details]
0003: patch for 3.0.1

approved!
Comment 15 linpct 2016-08-26 04:42:00 UTC
Comment on attachment 174057 [details]
0001: armv6 additions

would this still work on 3.0.1?
Comment 16 Franco Fichtner 2016-08-26 08:57:43 UTC
Created attachment 174089 [details]
ARMv6 build log for Phalcon 3.0.1 on PHP 5.6

I've attached an OPNsense build log as I don't have Poudriere set up to cross-build.  Works fine.
Comment 17 Torsten Zuehlsdorff freebsd_committer 2016-08-31 08:50:59 UTC
So i'm confused right now. Which patch to apply/test/commit? Is there one big to check?
Comment 18 Franco Fichtner 2016-08-31 09:10:13 UTC
This has been rather confusing and time-consuming...

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=211359 added ARMv6 support and should have been approved by maintainer timeout a while back. It was falsely closed as a duplicate. ;)

This armv6 support patch is now incorporated into this issue as patch 0001 by request of koobs@.

The next patch 0002 builds on top of 0001 and adds 3.0.0.  It was approved by the maintainer.

The next patch 0003 builds on top of 0002 and adds 3.0.1 as per request of the maintainer.  It was also approved.

Do you want me to condense all the patches into a single one?
Comment 19 Torsten Zuehlsdorff freebsd_committer 2016-08-31 12:41:53 UTC
(In reply to Franco Fichtner from comment #18)

> Do you want me to condense all the patches into a single one?

No thanks, i did it by myself with your explanation. Testbuilds are running now. :)
Comment 20 Franco Fichtner 2016-09-19 06:15:12 UTC
Good morning,

Looks like this is still pending.  :)


Cheers,
Franco
Comment 21 Torsten Zuehlsdorff freebsd_committer 2016-09-20 11:29:01 UTC
(In reply to Franco Fichtner from comment #20)

> Looks like this is still pending.  :)

Yes, i'm sorry. Wife got ill, to less time, etc. :/

Since i'm coming back right now i think i will get this PR done tomorrow. :)
Comment 22 commit-hook freebsd_committer 2016-09-23 08:28:51 UTC
A commit references this bug:

Author: tz
Date: Fri Sep 23 08:27:59 UTC 2016
New revision: 422653
URL: https://svnweb.freebsd.org/changeset/ports/422653

Log:
  www/phalcon: Update from 2.0.13 to 3.0.1

  Changes: https://github.com/phalcon/cphalcon/blob/v3.0.1/CHANGELOG.md

  Also add arm6 support

  PR:           211923
  Submitted by: Franco Fichtner <franco@opnsense.org>
  Approved by:  linpct@gmail.com (maintainer), swills (mentor)

Changes:
  head/www/phalcon/Makefile
  head/www/phalcon/distinfo
Comment 23 Torsten Zuehlsdorff freebsd_committer 2016-09-23 09:02:56 UTC
Committed, thanks :)