Bug 211925 - etcupdate(8) warns about missing dirs during 10.3R -> 11.0RC1 update without /usr/src
Summary: etcupdate(8) warns about missing dirs during 10.3R -> 11.0RC1 update without ...
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.0-RC1
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-17 06:50 UTC by Dave Cottlehuber
Modified: 2017-02-13 21:48 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Cottlehuber freebsd_committer 2016-08-17 06:50:18 UTC
# issue

Various warnings occur during upgrade:

```
Installing updates...install: ///var/db/etcupdate/current/etc/devd/ulpt.conf: No such file or directory
install: ///var/db/etcupdate/current/etc/mtree/BSD.lib32.dist: No such file or directory
install: ///var/db/etcupdate/current/etc/mtree/BSD.tests.dist: No such file or directory
install: ///var/db/etcupdate/current/etc/periodic/daily/430.status-uptime: No such file or directory
install: ///var/db/etcupdate/current/etc/rc.d/blacklistd: No such file or directory
install: ///var/db/etcupdate/current/etc/rc.d/iovctl: No such file or directory
install: ///var/db/etcupdate/current/etc/rc.d/ypldap: No such file or directory
install: ///var/db/etcupdate/current/etc/rc.d/zfsd: No such file or directory

Completing this upgrade requires removing old shared object files.
Please rebuild all installed 3rd party software (e.g., programs
installed from the ports tree) and then run "/usr/sbin/freebsd-update install"
again to finish installing updates.
```

/var/db/etcupdate/current/etc/{rc.d,mtree,devd,periodic} are all missing. Other systems that were upgrading through 11.0-BETA have not had this issue.

filesystem looks like:

```
root@mrbrown:/var/db/etcupdate/current/etc # tree -aF
.
|-- blacklistd.conf
|-- casper/
|   |-- system.dns
|   |-- system.grp
|   |-- system.pwd
|   |-- system.random
|   `-- system.sysctl
`-- dma/
    `-- dma.conf

2 directories, 7 files
```

# expected results

If the missing directories are not significant, then the warnings should be suppressed.

If they are significant, then etcupdate should create them correctly.

# notes

system is a vanilla 10.3R amd64 box, not built from src, and without /usr/src/ present. All other systems I have upgraded without issue have had /usr/src present.

It would be nice if etcupdate had a way of bootstrapping itself without needing /usr/src/ present, if that's appropriate I will do another BZ.
Comment 1 Dave Cottlehuber freebsd_committer 2017-02-13 21:48:29 UTC
not reproducible with 11.0R anymore.