Bug 211981 - FBSD 11.0 RC1 package URL info incorrect for RPI-B image
Summary: FBSD 11.0 RC1 package URL info incorrect for RPI-B image
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Many People
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-19 06:34 UTC by Bob Frazier
Modified: 2019-09-05 09:30 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Frazier 2016-08-19 06:34:59 UTC
After downloading and copying FreeBSD 11.0 RC1 image for RPI-B onto an SD card, and successfully booting it up, I attempted to use 'pkg' and it was unable to locate the package information.

After going through the trouble of getting the ports collection and installing it via the port, I discovered the cause:  it was looking in the wrong place.

The path it was attempting to use was (similar to)

  http://pkg.FreeBSD.org/freebsd11:armv6/quarterly

(this may not be the exact one but it illustrates the point)

But the correct path should be

  http://pkg.FreeBSD.org/freebsd:11:armv6:32:el:eabi:softfp/latest

To correct for this, I made two modifications to configuration files as a workaround.

The first was to the /etc/pkg/FreeBSD.conf file

(removed this line)
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/quarterly",
(added this line)
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",


The second was to the /usr/local/etc/pkg.conf file

(line added)
ABI = "freebsd:11:armv6:32:el:eabi:softfp"


Making these changes caused the pkg application to correctly install packages.

I would do this as a 'diff' but I didn't keep the originals and don't really want to re-generate them just to do a diff.  Since the changes are simple enough, I described them here.