Bug 212129 - [new port] cad/libopencad: Library written in C++11, which provides a way to read/write CAD (DWG/DXF/DXFB) files
Summary: [new port] cad/libopencad: Library written in C++11, which provides a way to...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL: https://wiki.osgeo.org/wiki/GDALDWG_S...
Keywords: feature, needs-qa
Depends on:
Blocks:
 
Reported: 2016-08-25 05:10 UTC by Loïc Bartoletti
Modified: 2016-12-26 14:41 UTC (History)
3 users (show)

See Also:


Attachments
libopencad port (3.79 KB, text/plain)
2016-08-25 05:10 UTC, Loïc Bartoletti
no flags Details
libopencad port (4.01 KB, text/plain)
2016-08-27 12:34 UTC, Loïc Bartoletti
no flags Details
libopencad remove i386 restriction (5.29 KB, text/plain)
2016-09-21 20:33 UTC, Loïc Bartoletti
lbartoletti: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Bartoletti freebsd_committer 2016-08-25 05:10:12 UTC
Created attachment 174042 [details]
libopencad port

Libopencad is a MIT library for support DWG cad files. It will be a dependency for GDAL DWG driver. 
It was started as a SoC.

See also:
https://trac.osgeo.org/gdal/wiki/DWG_driver
https://github.com/sandyre/libopencad
https://gsoc2016gdaldwg.blogspot.fr/
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-25 08:17:35 UTC
Please confirm this port passes QA (at least portlint, poudriere). For more information and instructions see:

https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/testing.html

A shorter COMMENT may also be warranted, perhaps:

"Library to work with CAD (DWG/DXF/DXFB) files"
Comment 2 Loïc Bartoletti freebsd_committer 2016-08-27 12:34:45 UTC
Created attachment 174118 [details]
libopencad port

New port.

Portlint -Nabt: ok
Poudriere 10, 11, 12 amd64 OK
Poudriere 10, 11, 12 i386 doesn't compile see my comment and then opened issue (https://github.com/sandyre/libopencad/issues/30).
Comment 3 Denis Rykov 2016-09-11 01:39:35 UTC
It looks like issue was already fixed, could you try to compile libopencad again?
Comment 4 Loïc Bartoletti freebsd_committer 2016-09-21 20:33:00 UTC
Created attachment 175039 [details]
libopencad remove i386 restriction
Comment 5 Dmitry Marakasov freebsd_committer 2016-12-26 14:29:10 UTC
Committed with minor changes:

- Add LICENSE_FILE
- Fix compiler requirement
- Mark BROKEN on FreeBSD 9
- Reformat pkg-descr in more readable way
Comment 6 commit-hook freebsd_committer 2016-12-26 14:29:19 UTC
A commit references this bug:

Author: amdmi3
Date: Mon Dec 26 14:29:07 UTC 2016
New revision: 429524
URL: https://svnweb.freebsd.org/changeset/ports/429524

Log:
  Libopencad is a library written in C++11, which provides a way to
  read/write CAD  (DWG/DXF/DXFB) files. It was designed to have a
  uniformal API to work with any CAD files.

  It has a base class - CADFile.

  Inheriting this class it's possible to create a driver for any CAD
  format, all you need to do - is to overwrite interface functions
  like GetGeometry(index), and others.

  Now it has an implementation for DWG2000 (R15), but only for read.

  Library comes with cadinfo utility, which prints out everything
  library can get from file - header variables, CAD custom classes,
  presented layers and geometries with their attributes.

  WWW: https://trac.osgeo.org/gdal/wiki/DWG_driver

  PR:		212129
  Submitted by:	lbartoletti@tuxfamily.org

Changes:
  head/cad/Makefile
  head/cad/libopencad/
  head/cad/libopencad/Makefile
  head/cad/libopencad/distinfo
  head/cad/libopencad/files/
  head/cad/libopencad/files/patch-lib_cadheader.cpp
  head/cad/libopencad/files/patch-lib_cadheader.h
  head/cad/libopencad/files/patch-tests_CMakeLists.txt
  head/cad/libopencad/pkg-descr
  head/cad/libopencad/pkg-plist
Comment 7 Denis Rykov 2016-12-26 14:41:31 UTC
There are many improvement happened in libopencad last month. Previously used repository (https://github.com/sandyre/libopencad) is not relevant now, all further development will be in https://github.com/nextgis-borsch/lib_opencad repository. Please take it into account.