Bug 212134 - Mk/Uses/cran.mk: fix WARNING due to object files in source
Summary: Mk/Uses/cran.mk: fix WARNING due to object files in source
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: David Naylor
URL:
Keywords: easy, patch
: 212135 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-25 06:59 UTC by David Naylor
Modified: 2016-08-26 20:43 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+
koobs: merge-quarterly?


Attachments
Remove object files from source (408 bytes, patch)
2016-08-25 06:59 UTC, David Naylor
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Naylor freebsd_committer 2016-08-25 06:59:37 UTC
Created attachment 174047 [details]
Remove object files from source

R tests complain if there are .o and .so objects in the source code (i.e. it expects a clean source directory).  

The attached patch cleans up before running the tests.
Comment 1 David Naylor freebsd_committer 2016-08-25 07:04:46 UTC
*** Bug 212135 has been marked as a duplicate of this bug. ***
Comment 2 Wen Heping freebsd_committer 2016-08-25 07:58:59 UTC
Please go ahead.

Please feel free to take maintainership of cran.mk.

Thank you !

wen
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-25 08:05:15 UTC
Should this be MFH'd ?
Comment 4 commit-hook freebsd_committer 2016-08-26 20:31:06 UTC
A commit references this bug:

Author: dbn
Date: Fri Aug 26 20:30:18 UTC 2016
New revision: 420948
URL: https://svnweb.freebsd.org/changeset/ports/420948

Log:
  Mk/Uses/cran.mk: fix WARNING in cran tests.

  R warns if it detects .o or .so objects in the source directory, when
  running tests.  Remove the offending files before running the test.

  Take maintainership [1]

  PR:		212134
  Approved by:	wen [1]

Changes:
  head/Mk/Uses/cran.mk
Comment 5 David Naylor freebsd_committer 2016-08-26 20:43:04 UTC
Commited, and taken maintainership.  Thank you for maintaining cran to this point :-D