Bug 212292 - [patch] mail/neomutt: add NCURSES/SLANG selection to OPTIONS because of bug
Summary: [patch] mail/neomutt: add NCURSES/SLANG selection to OPTIONS because of bug
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Baptiste Daroussin
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-08-31 17:53 UTC by Kurt Jaeger
Modified: 2017-03-12 14:28 UTC (History)
2 users (show)

See Also:


Attachments
patch (1.14 KB, patch)
2016-08-31 17:55 UTC, Kurt Jaeger
no flags Details | Diff
buggy.jpg (62.22 KB, image/jpeg)
2016-08-31 17:56 UTC, Kurt Jaeger
no flags Details
with-slang.jpg (61.62 KB, image/jpeg)
2016-08-31 17:56 UTC, Kurt Jaeger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2016-08-31 17:53:43 UTC

    
Comment 1 Kurt Jaeger freebsd_committer 2016-08-31 17:55:37 UTC
Created attachment 174261 [details]
patch

mutt compiled with NCURSES instead of SLANG has a buggy thread display.

neomutt does not have the OPTION to select SLANG, added in the patch.

For examples how the bug see the attached two screendumps.
Comment 2 Kurt Jaeger freebsd_committer 2016-08-31 17:56:13 UTC
Created attachment 174262 [details]
buggy.jpg

The buggy thread-display.
Comment 3 Kurt Jaeger freebsd_committer 2016-08-31 17:56:54 UTC
Created attachment 174263 [details]
with-slang.jpg

The thread display compiled with SLANG
Comment 4 Baptiste Daroussin freebsd_committer 2016-11-26 14:23:55 UTC
I cannot reproduce the bug and it would be nice if you provide more inputs about you env variables: locales, encoding etc (LANG, LC_*)

I would prefer not to add a SLANG option if possible but rather fix/understand the issue you are facing with ncurses
Comment 5 commit-hook freebsd_committer 2017-03-12 14:28:39 UTC
A commit references this bug:

Author: bapt
Date: Sun Mar 12 14:28:26 UTC 2017
New revision: 435988
URL: https://svnweb.freebsd.org/changeset/ports/435988

Log:
  Update to 2017-03-06
  Add an option for slang support[1]

  PR:		217464, 212292
  Submitted by:	krion, pi

Changes:
  head/mail/neomutt/Makefile
  head/mail/neomutt/distinfo
  head/mail/neomutt/files/patch-getdomain.c
  head/mail/neomutt/files/pkg-message.slang