Bug 212348 - 11.0-RC2 and 12-CURRENT serial console not working while installing on apu2c4
Summary: 11.0-RC2 and 12-CURRENT serial console not working while installing on apu2c4
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-03 10:41 UTC by Oliver Boettcher
Modified: 2016-09-05 10:33 UTC (History)
2 users (show)

See Also:


Attachments
APU2C4 Boot hangs (123.66 KB, image/png)
2016-09-03 10:41 UTC, Oliver Boettcher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Boettcher 2016-09-03 10:41:59 UTC
Created attachment 174332 [details]
APU2C4 Boot hangs

Hardware: apu2c4 (http://www.pcengines.ch/apu2c4.htm)
Wifi-Card attached: Compex WLE600NX
mSATA drive attached: Samsung SSD 850 Evo

I tried to install 11.0-RC2 on an apu2c4 which stucks on boot and waits forever (screenshot attached). So I tried to install 10.3-RELEASE which installed without problems and updated to 11.0-RC2 via freebsd-update, rebooted, hangs right after loading the kernel.

I also tried 12-CURRENT but no luck either.

I don't know how to track down this problem. If I can supply further investigation, please let me know.

Kind Regards
Oliver

Initial Maillinglist discussion here: https://lists.freebsd.org/pipermail/freebsd-current/2016-September/063180.html
Comment 1 Oliver Boettcher 2016-09-03 10:53:40 UTC
Sorry I just noticed that the update from 10.3-RELEASE to 11.0-RC2 worked but the redirection to serial console does not on 11.0 and 12-CURRENT.

That also prevents installing from memory stick via serial console.

I dont know if this is still a bug.

Kind Regards
Oliver
Comment 2 Oliver Boettcher 2016-09-03 17:08:07 UTC
It turned out that I have to set

console="comconsole"
comconsole_speed="115200"

in loader.conf to get a serial console.

But this still prevents to get 11.0 to get installed on that device.

Cheers
Oliver
Comment 3 marek 2016-09-05 10:33:49 UTC
Hi, I successfully installed FreeBSD 11.0-RC2 by adding to /boot/loader.conf following lines:

boot_serial="YES"
comconsole_speed="115200"
console="comconsole"

I modified memstick image, then successfully booted it on apu2c4.