Bug 212363 - devel/ocl-icd: Update to 2.2.9
Summary: devel/ocl-icd: Update to 2.2.9
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Koop Mast
URL:
Keywords: needs-qa, patch
: 206780 (view as bug list)
Depends on: 212362
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-04 07:30 UTC by O. Hartmann
Modified: 2016-10-22 12:03 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (ohartmann)


Attachments
ocl-icd.2.2.9.diff (1.58 KB, patch)
2016-09-04 07:30 UTC, O. Hartmann
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2016-09-04 07:30:36 UTC
Created attachment 174360 [details]
ocl-icd.2.2.9.diff

the ICD loader ocl-icd has been updated to 2.2.9 and relies on OpenCL API >= 2.0. This patchset reflects the update.
Comment 1 O. Hartmann 2016-09-10 17:00:11 UTC
*** Bug 206780 has been marked as a duplicate of this bug. ***
Comment 2 O. Hartmann 2016-09-12 06:44:37 UTC
I checked the port/patch/diff in strain with the ongoing work on importing POCL (PR ). The port has been tested within my poudriere environment and builds fine from scratch.

Until now, I haven't had the chance to test the port with POCL thoroughly to confirm its correctnes in terms of its functionality.

What is needed to confirm here its "ready for implanting' into the ports tree?
Comment 3 Koop Mast freebsd_committer 2016-09-13 19:00:08 UTC
Just a few notes, no need to update the patch.

You added back ${PORTSDIR} in *_DEPENDS lines this is no longer needed so I removed them.
And I replaced The CPPFLAGS/LDFLAGS with USES=localbase.
I also added a version to the opencl since it requires opencl >= 2.1

After opencl is updated I will commit this port too.
Comment 4 commit-hook freebsd_committer 2016-10-22 12:02:44 UTC
A commit references this bug:

Author: kwm
Date: Sat Oct 22 12:02:24 UTC 2016
New revision: 424467
URL: https://svnweb.freebsd.org/changeset/ports/424467

Log:
  Update ocl-icd to 2.2.9.

  * Add minimal version to the opencl build dependancy.
  * Replace CPPFLAGS/LDFLAGS with USES=localbase.

  PR:		212363
  Submitted by:	maintainer

Changes:
  head/devel/ocl-icd/Makefile
  head/devel/ocl-icd/distinfo
Comment 5 Koop Mast freebsd_committer 2016-10-22 12:03:22 UTC
Committed thanks!