Bug 212365 - [PATCH] net-p2p/retroshare: Add upstream patches to fix the build in C++11 mode
Summary: [PATCH] net-p2p/retroshare: Add upstream patches to fix the build in C++11 mode
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: patch
Depends on:
Blocks: 211916
  Show dependency treegraph
 
Reported: 2016-09-04 08:08 UTC by Raphael Kubo da Costa
Modified: 2016-09-04 11:52 UTC (History)
2 users (show)

See Also:


Attachments
Proposed patch (18.51 KB, patch)
2016-09-04 08:09 UTC, Raphael Kubo da Costa
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa freebsd_committer 2016-09-04 08:08:33 UTC
Starting with the upcoming Qt 5.6 port, Qt will automatically pass -std=gnu++11 (or equivalent) when it detects it's supported by the compiler.

RetroShare currently fails to build in C++11 mode, and the attached upstream patches fix the failures. One of them, patch-git_5e94c772, allows some home-grown patches to be removed.

All those changes being backported are part of v0.6.1, released a few days ago.
Comment 1 Raphael Kubo da Costa freebsd_committer 2016-09-04 08:09:54 UTC
Created attachment 174361 [details]
Proposed patch
Comment 2 Kurt Jaeger freebsd_committer 2016-09-04 11:19:33 UTC
Are you aware of PR#210682 ? Does that patch still apply after that PR ?
Comment 3 Raphael Kubo da Costa freebsd_committer 2016-09-04 11:25:48 UTC
Bug 210682 is just picking a random git revision to use instead of an official release; it includes some of the changes in files/ done here simply because they are present in the git revision included there. Since I don't use RetroShare myself, I've chosen to just include the necessary patches to allow kde@ to proceed with the Qt 5.6 update.
Comment 4 Kurt Jaeger freebsd_committer 2016-09-04 11:28:52 UTC
PR#210682 already has maintainer approval, so if we speed up on that PR, wouldn't that help KDE as well ?
Comment 5 Raphael Kubo da Costa freebsd_committer 2016-09-04 11:45:13 UTC
That's true (even though updating to random revisions feels weird to me); I can confirm that the patch in that PR is enough to fix the build with Qt 5.6 too. Will you take care of landing that one given your comment there?
Comment 6 Kurt Jaeger freebsd_committer 2016-09-04 11:49:34 UTC
Yes, I'm testbuilding right now. If it works out, I'll commit PR#210682
Comment 7 Raphael Kubo da Costa freebsd_committer 2016-09-04 11:52:48 UTC
OK then, thanks!