Bug 212374 - [update] update net/sngrep to latest 1.4.0
Summary: [update] update net/sngrep to latest 1.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-04 18:20 UTC by Talal Al Dik
Modified: 2016-09-10 13:11 UTC (History)
0 users

See Also:


Attachments
update patch from sngrep_1.3.1 to sngrep _1.4.0 (1.04 KB, text/plain)
2016-09-04 18:20 UTC, Talal Al Dik
no flags Details
diff -ruN sngrep.1.3.1 sngrep.1.4.0 (1.02 KB, patch)
2016-09-09 23:41 UTC, Talal Al Dik
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Talal Al Dik 2016-09-04 18:20:38 UTC
Created attachment 174376 [details]
update patch from sngrep_1.3.1 to sngrep _1.4.0

# diff -ruN /usr/ports/net/sngrep-old1.31 /usr/ports/net/sngrep
Comment 1 Dmitry Marakasov freebsd_committer 2016-09-05 15:27:27 UTC
The patch does not apply, has CRLF line endings.
Comment 2 Talal Al Dik 2016-09-09 23:41:48 UTC
Created attachment 174596 [details]
diff -ruN sngrep.1.3.1 sngrep.1.4.0

strange, I had pasted the diff directly on bugzilla'a web interface, it shouldn't have added CRLF. 
Anyway, here is the file without CRLF.
Comment 3 commit-hook freebsd_committer 2016-09-10 13:11:53 UTC
A commit references this bug:

Author: amdmi3
Date: Sat Sep 10 13:11:31 UTC 2016
New revision: 421689
URL: https://svnweb.freebsd.org/changeset/ports/421689

Log:
  - Update to 1.4.0
  - While here
    - Fix LICENSE
    - Switch to USES=ssl
    - Switch to USES=localbase, remove unneeded MAKE_ARGS
    - Remove unneeded options.mk inclusion

  PR:		212374
  Submitted by:	tad@vif.com (maintainer)

Changes:
  head/net/sngrep/Makefile
  head/net/sngrep/distinfo