Bug 212411 - audio/speex: fix build with --disable-silent-rules
Summary: audio/speex: fix build with --disable-silent-rules
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL:
Keywords: easy
Depends on:
Blocks: 212075
  Show dependency treegraph
 
Reported: 2016-09-06 13:30 UTC by Dmitry Marakasov
Modified: 2016-09-09 19:25 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (multimedia)
koobs: merge-quarterly?


Attachments
Patch (946 bytes, patch)
2016-09-06 13:30 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2016-09-06 13:30:03 UTC
Created attachment 174414 [details]
Patch

Exp-run with --disable-silent-rules added to CONFIGURE_ARGS showed failure for audio/speex. It's caused by broken configure script which checks $enableval after checking for corresponding --enable/--disable option, but if option was not set, enableval value left from the previous (unrelated) option is used. As result, $enableval=no set by check in --disable-silent-rules also turns off binaries as if --disable-binaries was given. To fix that, unset $enableval after silent-rules processing.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-09-08 09:52:17 UTC
@Dmitry These appear to be blanket (implicit approval, just fix it if well tested/QA'd) changes. Feel free to assign/commit/mfh
Comment 2 commit-hook freebsd_committer 2016-09-09 19:25:28 UTC
A commit references this bug:

Author: amdmi3
Date: Fri Sep  9 19:24:33 UTC 2016
New revision: 421630
URL: https://svnweb.freebsd.org/changeset/ports/421630

Log:
  - Fix build with --disable-silent-rules

  PR:		212411
  Submitted by:	amdmi3
  Approved by:	portmgr

Changes:
  head/audio/speex/files/
  head/audio/speex/files/patch-configure