Bug 212548 - sbin/reboot/reboot.8 - Amend HISTORY
Summary: sbin/reboot/reboot.8 - Amend HISTORY
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-doc (Nobody)
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-09-10 03:04 UTC by Sevan Janiyan
Modified: 2018-03-15 09:49 UTC (History)
1 user (show)

See Also:


Attachments
reboot(8) - Ammend HISTORY (398 bytes, patch)
2016-09-10 03:04 UTC, Sevan Janiyan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sevan Janiyan 2016-09-10 03:04:46 UTC
Created attachment 174606 [details]
reboot(8) - Ammend HISTORY

A standalone reboot utility showed up in 4.0BSD, in AT&T UNIX init has a case for reboot and is present in the version shipped with V5 (either way, current entry is incorrect).
Bump date.
Comment 1 Sevan Janiyan 2016-09-13 23:13:37 UTC
Not going to close this, but the history of this command is not that straight forward. hence the current patch should not be commited.
http://mail-index.netbsd.org/source-changes-d/2016/09/13/msg008686.html
Comment 2 Sevan Janiyan 2016-09-13 23:17:43 UTC
(In reply to Sevan Janiyan from comment #1)
It's getting late, previous comment is intended for the src/sbin/shutdown ticket. please ignore.
Comment 3 commit-hook freebsd_committer 2016-09-16 04:11:53 UTC
A commit references this bug:

Author: allanjude
Date: Fri Sep 16 04:11:04 UTC 2016
New revision: 305858
URL: https://svnweb.freebsd.org/changeset/base/305858

Log:
  sbin/reboot/reboot.8: Amend HISTORY

  A standalone reboot utility showed up in 4.0BSD, in AT&T UNIX init has a
  case for reboot and is present in the version shipped with V5

  either way, current entry is incorrect.

  PR:		212548
  Submitted by:	Sevan Janiyan <venture37@geeklan.co.uk>

Changes:
  head/sbin/reboot/reboot.8
Comment 4 commit-hook freebsd_committer 2018-03-15 09:49:52 UTC
A commit references this bug:

Author: eadler
Date: Thu Mar 15 09:49:23 UTC 2018
New revision: 330983
URL: https://svnweb.freebsd.org/changeset/base/330983

Log:
  MFC r305857,r305858,r305859:

  sbin/rcorder/rcorder.8: Amend HISTORY

  rcorder appeared in FreeBSD 5.0.
  Address issues raised by igor.

  PR:		212547
  Submitted by:	Sevan Janiyan <venture37@geeklan.co.uk>

  ------------------------------------------------------------------------
  r305858 | allanjude | 2016-09-16 04:11:04 +0000 (Fri, 16 Sep 2016) | 10 lines

  sbin/reboot/reboot.8: Amend HISTORY

  A standalone reboot utility showed up in 4.0BSD, in AT&T UNIX init has a
  case for reboot and is present in the version shipped with V5

  either way, current entry is incorrect.

  PR:		212548
  Submitted by:	Sevan Janiyan <venture37@geeklan.co.uk>

  ------------------------------------------------------------------------
  r305859 | allanjude | 2016-09-16 04:12:32 +0000 (Fri, 16 Sep 2016) | 8 lines

  sbin/umount/umount.8: Amend HISTORY

  umount first appeared in V1, confirmed using TUHS archive
  http://minnie.tuhs.org/cgi-bin/utree.pl?file=V1/man/man1/umount.1

  PR:		212554
  Submitted by:	Sevan Janiyan <venture37@geeklan.co.uk>

Changes:
_U  stable/11/
  stable/11/sbin/rcorder/rcorder.8