Bug 212611 - emulators/virtualbox-ose-additions 5.1.4: OpenGL support broken (regression)
Summary: emulators/virtualbox-ose-additions 5.1.4: OpenGL support broken (regression)
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-12 17:13 UTC by Martin Birgmeier
Modified: 2018-01-14 03:30 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2016-09-12 17:13:26 UTC
Scenario:
- virtualbox-ose-additions-5.1.4 built with options DBUS, OPENGL, and X11 set
- installed in a virtual machine:
  . host os = FreeBSD 10.3
  . host virt = virtualbox-ose-5.1.4
  . client os = FreeBSD 10.3
  . vbox additions = as built above
- starting programs using OpenGL

Result:
- these programs stop with exit code 1, in most cases without any further output
- Examples:

[0]% firefox
[1]% glxgears
[1]% glxinfo
name of display: :0
[1]% 

Expected result:
- firefox should start
- glxgears should show the spinning gears
- glxinfo should show the supported extensions etc.

Notes:
- This worked up to 5.0.26.
- Installing the additions on a machine which is *not* virtualized leads to the same erroneous behavior.
Comment 1 otacilio.neto 2016-09-12 19:55:35 UTC
Dear, I have a environment very similar to your except that the host machine is a Windows 10. This same behavior I saw here when I have installed Virtualbox-ose-additions, but the option "Enable 3D acceleration" in virtual machine Monitor configuration was disabled. In previous Virtualbox-ose-additions this don't closes the programs, only causes a worst performance, but, when using new virtualbox-ose-addtions (5.1.4) this misconfiguration causes  programs finalization.
Comment 2 Jung-uk Kim freebsd_committer 2016-09-13 05:38:12 UTC
It sounds like emulators/virtualbox-ose-additions was not properly installed.  Please try r421979 or later.  I just updated the port to 5.1.6 and made 3D acceleration hack more robust with libmap.conf(5).
Comment 3 Martin Birgmeier 2016-11-03 19:04:14 UTC
The latest scenario is that I am running virtualbox-ose-additions-5.1.8, with both host and client os 11.0-RELEASE-p2.

Firefox and glxgears still just quit.

I have also tried to enable 3G acceleration in the client vbox settings, to no avail.

-- Martin
Comment 4 w.schwarzenfeld freebsd_triage 2018-01-14 03:30:29 UTC
VBOX has 5.2.4. Seems overcome by events.