Bug 212714 - devel/hg-git: update past 0.8.5
Summary: devel/hg-git: update past 0.8.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ruslan Makhmatkhanov
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-09-15 23:31 UTC by Matthew Rezny
Modified: 2017-02-23 09:53 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (marco.broeder)


Attachments
update devel/hg-git to 0.8.5 (851 bytes, patch)
2016-09-15 23:31 UTC, Matthew Rezny
no flags Details | Diff
update devel/hg-git to current tip (1.18 KB, patch)
2016-09-25 11:35 UTC, Matthew Rezny
vlad-fbsd: maintainer-approval+
Details | Diff
update devel/hg-git to current tip (1.20 KB, patch)
2016-12-10 15:44 UTC, Matthew Rezny
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Rezny freebsd_committer 2016-09-15 23:31:04 UTC
Created attachment 174818 [details]
update devel/hg-git to 0.8.5

Update hg-git to 0.8.5 for compatibility with current (3.9) Mercurial. Attempting to use the previous version of hg-git with current hg results in an error stating the extension only supports version 3.6 of Mercurial.
Comment 1 Matthew Rezny freebsd_committer 2016-09-25 11:35:41 UTC
Created attachment 175153 [details]
update devel/hg-git to current tip

Oops, it seems 0.8.5 is only marked compatible with Mercurial 3.7, not sure why it ran one day and then not the next.

There is no newer release, but the version compat was bumped to hg 3.9 a half-dozen commits later, so use the current tip until there is another tagged release.
Comment 2 VK freebsd_triage 2016-11-12 22:55:36 UTC
Thanks for the patch. Please confirm the changes pass QA (portlint, poudriere).
Comment 3 VK freebsd_triage 2016-11-12 22:55:57 UTC
Comment on attachment 175153 [details]
update devel/hg-git to current tip

Maintainer TIMEOUT, implicit approval.
Comment 4 Matthew Rezny freebsd_committer 2016-11-16 11:31:34 UTC
This patch did pass QA, but in the two months that it has sat it has become outdated and irrelevant. Mercurial is now on version 4.0, and although there are a few more upstream (hg-git) commits, none mark the extension compatible with a version greater than 3.9, so this patch is currently only relevant to those who have held back their Mercurial port.
Comment 5 Carlo Strub freebsd_committer 2016-12-09 22:28:23 UTC

*** This bug has been marked as a duplicate of bug 213460 ***
Comment 6 Matthew Rezny freebsd_committer 2016-12-10 15:44:20 UTC
Created attachment 177852 [details]
update devel/hg-git to current tip

There has been a commit to hg-git to mark it compatible with Mercurial 4.0.1. I have updated the patch after brief testing so this PR is relevant again.
Comment 7 Matthew Rezny freebsd_committer 2016-12-10 15:47:03 UTC
Not a dupe, this PR was opened first and updates to a later version than the other.
Comment 8 commit-hook freebsd_committer 2017-02-20 21:04:22 UTC
A commit references this bug:

Author: rm
Date: Mon Feb 20 21:03:57 UTC 2017
New revision: 434489
URL: https://svnweb.freebsd.org/changeset/ports/434489

Log:
  devel/hg-git: update past 0.8.5

  Update hg-git to 0.8.5 + recent commits for compatibility with current Mercurial
  Attempting to use the previous version of hg-git with current hg results
  in an error stating the extension only supports version 3.6 of Mercurial.

  While here, add NO_ARCH and adjust python version.

  PR:		212714
  Submitted by:	matthew@reztek.cz
  Approved by:	maintainer timeout (month+)
  MFH:		2017Q1

Changes:
  head/devel/hg-git/Makefile
  head/devel/hg-git/distinfo
Comment 9 Ruslan Makhmatkhanov freebsd_committer 2017-02-20 21:06:06 UTC
Committed, thank you!
Comment 10 commit-hook freebsd_committer 2017-02-23 09:53:10 UTC
A commit references this bug:

Author: rm
Date: Thu Feb 23 09:52:05 UTC 2017
New revision: 434663
URL: https://svnweb.freebsd.org/changeset/ports/434663

Log:
  MFH: r434489

  devel/hg-git: update past 0.8.5

  Update hg-git to 0.8.5 + recent commits for compatibility with current Mercurial
  Attempting to use the previous version of hg-git with current hg results
  in an error stating the extension only supports version 3.6 of Mercurial.

  While here, add NO_ARCH and adjust python version.

  PR:		212714
  Submitted by:	matthew@reztek.cz
  Approved by:	maintainer timeout (month+)

  Approved by:	ports-secteam (junovitch)

Changes:
_U  branches/2017Q1/
  branches/2017Q1/devel/hg-git/Makefile
  branches/2017Q1/devel/hg-git/distinfo