Bug 212832 - [MAINTAINER] net-mgmt/collectd5: update to 5.6.0
Summary: [MAINTAINER] net-mgmt/collectd5: update to 5.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Joseph Mingrone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-19 21:07 UTC by Krzysztof
Modified: 2016-09-26 14:53 UTC (History)
4 users (show)

See Also:
ports: maintainer-feedback+


Attachments
collectd ver 5.6.0 (23.85 KB, patch)
2016-09-19 21:07 UTC, Krzysztof
ports: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof 2016-09-19 21:07:13 UTC
Created attachment 174974 [details]
collectd ver 5.6.0

There is new version of net-mgmt/collectd5. I've made a patch which updates collectd. Also I've checked it with my poudriere instance. You can check logfile. It is available by this url:
http://uld.bsdserwis.com/pkg/data/10x64-testing/2016-09-19_22h51m25s/logs/collectd5-5.6.0.log

I hope that this patch will be commited without problems.
Comment 1 Krzysztof 2016-09-19 21:08:10 UTC
importance change
Comment 2 Joseph Mingrone freebsd_committer 2016-09-21 17:13:38 UTC
The build fails on 9i386 and 9amd64.

disk.c:663: error: 'DSM_TOTAL_BUSY_TIME' undeclared (first use in this function)
depbase=`echo utils_cmd_putval.lo | sed 's|[^/]*$|.deps/&|;s|\.lo$||'`;\
disk.c:663: error: (Each undeclared identifier is reported only once
disk.c:663: error: for each function it appears in.)
disk.c:664: error: 'DSM_TOTAL_DURATION' undeclared (first use in this function)

Could you add a 9-specific patch for the problematic block in disk.c?
Comment 3 Krzysztof 2016-09-22 07:52:42 UTC
OK, I will try. On my testing poudriere disk.c patch was rejected. For me it seems that whole patch was introduced to collectd sources...
Comment 4 Krzysztof 2016-09-23 21:40:25 UTC
So I've made an investigation. I can see that this plugin is depending on /usr/include/devstat.h which is absent at 9.x system?

Unfortunatelly I have no 9.x box, so I'm not able to reproduce this error.

I can see that whole previous patch of disk.c file is added to disk.c file. So I don't know how to "repair" :-(((

Also I've not found any patch for FreeBSD 9.x version. Any suggestions?
Comment 5 Kevin Bowling freebsd_committer 2016-09-24 03:36:03 UTC
FreeBSD 9 lifecycle is almost complete, I'd suggest disabling the disk plugin with --enable-disk passed to autoconf.
Comment 6 Kevin Bowling freebsd_committer 2016-09-24 03:36:50 UTC
(In reply to Kevin Bowling from comment #5)
To clarify --disable-disk just for FreeBSD < 10
Comment 7 Joseph Mingrone freebsd_committer 2016-09-24 21:28:35 UTC
https://reviews.freebsd.org/D8028
Comment 8 Krzysztof 2016-09-25 09:59:07 UTC
OK, so we can close this PR?
Comment 9 commit-hook freebsd_committer 2016-09-26 14:52:20 UTC
A commit references this bug:

Author: jrm
Date: Mon Sep 26 14:52:00 UTC 2016
New revision: 422778
URL: https://svnweb.freebsd.org/changeset/ports/422778

Log:
  Update net-mgmt/collectd5 to version 5.6.0

  - new port options CHRONY and MQTT
  - disable disk plugin on FreeBSD 9.x due to missing OS files
  - various patch changes

  PR:		212832
  Submitted by:	ports@bsdserwis.com (maintainer)
  Reviewed by:	swills (mentor)
  Approved by:	swills (mentor)
  Differential Revision:	https://reviews.freebsd.org/D8028

Changes:
  head/net-mgmt/collectd5/Makefile
  head/net-mgmt/collectd5/distinfo
  head/net-mgmt/collectd5/files/patch-Makefile.am
  head/net-mgmt/collectd5/files/patch-configure.ac
  head/net-mgmt/collectd5/files/patch-src__Makefile.am
  head/net-mgmt/collectd5/files/patch-src__daemon__Makefile.am
  head/net-mgmt/collectd5/files/patch-src__daemon__collectd.h
  head/net-mgmt/collectd5/files/patch-src__dns.c
  head/net-mgmt/collectd5/files/patch-src__modbus.c
  head/net-mgmt/collectd5/files/patch-src_config.h.in
  head/net-mgmt/collectd5/files/patch-src_disk.c
  head/net-mgmt/collectd5/files/patch-src_write__mongodb.c
  head/net-mgmt/collectd5/files/patch-src_zfs__arc.c
  head/net-mgmt/collectd5/files/patch-version-gen.sh
  head/net-mgmt/collectd5/pkg-plist
Comment 10 Joseph Mingrone freebsd_committer 2016-09-26 14:53:47 UTC
Committed (with minor changes).  Thanks!