Bug 212864 - databases/riak: fix riak-admin subcommands
Summary: databases/riak: fix riak-admin subcommands
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bartek Rutkowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-20 18:35 UTC by Ruslan Makhmatkhanov
Modified: 2016-09-24 14:09 UTC (History)
0 users

See Also:
robak: maintainer-feedback+


Attachments
This patch is fixing riak-admin subcommands handling (2.06 KB, text/plain)
2016-09-20 18:35 UTC, Ruslan Makhmatkhanov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Makhmatkhanov freebsd_committer 2016-09-20 18:35:01 UTC
Created attachment 175013 [details]
This patch is fixing riak-admin subcommands handling

Right now riak-admin script, when running as root, is broken for any subcommands like `riak-admin cluster plan`. For example do:

# riak-admin cluster plan
Usage: riak-admin cluster <command>

With the patch:

# riak-admin cluster plan
There are no staged changes

The problem is in check_user function of env.sh, that is invoked in riak-admin and loses command line arguments. 

This patch fixes things to me. It is taken from riak2's env.sh
Please apply.

While here I also removed Riak from COMMENT and bumped PORTREVISION.
Comment 1 commit-hook freebsd_committer 2016-09-24 14:09:10 UTC
A commit references this bug:

Author: robak
Date: Sat Sep 24 14:08:48 UTC 2016
New revision: 422722
URL: https://svnweb.freebsd.org/changeset/ports/422722

Log:
  databases/riak: fix riak-admin command functionality

  * Fis issues around riak-admin functionality in env.sh script
  * Adjust COMMENT
  * Bump PORTREVISION

  PR:		212864
  Submitted by:	rm
  MFH:		2016Q3

Changes:
  head/databases/riak/Makefile
  head/databases/riak/files/patch-deps-node_package-priv-base-env.sh
Comment 2 Bartek Rutkowski freebsd_committer 2016-09-24 14:09:47 UTC
Committed, thanks!