Bug 212884 - databases/luadbi: New repository location on Github
Summary: databases/luadbi: New repository location on Github
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: patch
: 213186 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-21 17:02 UTC by Michael
Modified: 2017-03-14 18:25 UTC (History)
5 users (show)

See Also:
olexander.v.melnyk: maintainer-feedback+


Attachments
Change a download location and change a portrevision. (2.89 KB, patch)
2016-10-03 11:12 UTC, olexander.v.melnyk
olexander.v.melnyk: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2016-09-21 17:02:37 UTC
The LuaDBI code has been made available by one of the Prosody developers in the following Github repository:

https://github.com/mwild1/luadbi

Please also refer to upstream bug:
https://prosody.im/issues/issue/747

It would be great if we could fetch LuaDBI from there and thus unbreak the installation of Prosody.
Comment 1 olexander.v.melnyk 2016-09-22 06:52:20 UTC
Thanks for your advice, I will do it.
Comment 2 Michael 2016-09-22 08:04:59 UTC
Please hold on for while, I just noticed that there are no tags or version numbers in the repo. I will file a bug upstream and ask them to add at least a "v0.5" tag, so that  we don't have to mess around with git commit hashes.
Comment 3 Michael 2016-09-22 08:18:21 UTC
I filed the issue here:
https://github.com/mwild1/luadbi/issues/36
Comment 4 olexander.v.melnyk 2016-10-03 11:12:50 UTC
Created attachment 175384 [details]
Change a download location and change a portrevision.
Comment 5 VK freebsd_triage 2016-10-04 09:24:46 UTC
*** Bug 213186 has been marked as a duplicate of this bug. ***
Comment 6 VK freebsd_triage 2016-10-04 09:26:24 UTC
Comment on attachment 175384 [details]
Change a download location and change a portrevision.

Thanks for the patch. Please set maintainer-approval+ flag on attachments for ports you're maintainer of, to help us track the issue better.
Comment 7 Michael 2016-10-23 12:56:56 UTC
A month has passed since I filed the bug about the missing tags in LuaDBI's Github repo and the issue has not been fixed yet.

I suggest we do not wait any more for upstream, but unbreak LuaDBI now by the above patch.

If a download from the official repo is desired: I diffed the repository's commits against the original tarball from Google Code and found the following commit to be an exact match, so we could use this link as download location as well:

https://github.com/mwild1/luadbi/archive/58513d50e800f6a4d4e999f9682c747c087eab6f.tar.gz
Comment 8 olexander.v.melnyk 2016-10-23 13:24:38 UTC
(In reply to Vladimir Krstulja from comment #6)
I set the flag, what's next?
Comment 9 VK freebsd_triage 2016-10-23 13:33:58 UTC
(In reply to olexander.v.melnyk from comment #8)

You approved the patch, as the maintainer of the port in question, that's what the flag is for, so now a committer has to take this issue and resolve.
Comment 10 Zilon 2016-12-08 20:01:52 UTC
Any idea why this has not been committed, yet?
Comment 11 tboston 2016-12-16 12:58:07 UTC
Now where is this one hanging?
Comment 12 Zilon 2017-01-22 12:09:38 UTC
Maybe a pull request witch the patch at this repo https://github.com/freebsd/freebsd-ports/tree/master/databases/luadbi would help?
Comment 13 Michael 2017-01-22 12:20:52 UTC
(In reply to Zilon from comment #12)

Nope, sorry, that's a read-only mirror of the ports tree ;-)
Comment 14 Michael 2017-03-14 17:09:52 UTC
I just sent a mail to the ports mailing list, maybe that helps.
Comment 15 Kurt Jaeger freebsd_committer 2017-03-14 17:55:31 UTC
testbuilds@work
Comment 16 commit-hook freebsd_committer 2017-03-14 18:22:23 UTC
A commit references this bug:

Author: pi
Date: Tue Mar 14 18:21:50 UTC 2017
New revision: 436168
URL: https://svnweb.freebsd.org/changeset/ports/436168

Log:
  databases/luadbi: unbreak with new distsite

  PR:		212884
  Submitted by:	Olexander Melnyk <olexander.v.melnyk@gmail.com> (maintainer)
  Reviewed by:	Michael Pfeiffer <michael.pfeiffer@eichenstein.de>

Changes:
  head/databases/luadbi/Makefile
  head/databases/luadbi/distinfo
  head/databases/luadbi/files/patch-Makefile
Comment 17 Kurt Jaeger freebsd_committer 2017-03-14 18:25:19 UTC
Committed, thanks!