Bug 212903 - Fix for www/webkit-gtk2 on powerpc
Summary: Fix for www/webkit-gtk2 on powerpc
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: powerpc Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-22 14:54 UTC by Justin Hibbits
Modified: 2017-03-11 21:18 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
Fix for webkit-gtk2 to build for powerpc and powerpc64 (424 bytes, patch)
2016-09-22 14:54 UTC, Justin Hibbits
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Hibbits freebsd_committer 2016-09-22 14:54:31 UTC
Created attachment 175066 [details]
Fix for webkit-gtk2 to build for powerpc and powerpc64

www/webkit-gtk2 fails to build for powerpc and powerpc64 targets due to always enabling the JavascriptCore MacroAssembler, even though it hasn't been ported to PowerPC.  The attached patch allows it to build and run on powerpc64 (tested right now, typing this in with midori browser).
Comment 1 commit-hook freebsd_committer 2017-03-11 21:16:07 UTC
A commit references this bug:

Author: rezny
Date: Sat Mar 11 21:15:03 UTC 2017
New revision: 435961
URL: https://svnweb.freebsd.org/changeset/ports/435961

Log:
  - Fix building on PPC/PPC64 [1]
  - Fix building on ARMv6 [2]
  - Add missing indirect dependencies
  - Possibly fix build on sparc64 (unconfirmed)

  PR:	212903 [1]
  Submitted by:	jhibbits [1], strejda [2]
  Approved by:	swills (mentor)
  Differential Revision:	https://reviews.freebsd.org/D9924

Changes:
  head/www/webkit-gtk2/Makefile
  head/www/webkit-gtk2/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h
  head/www/webkit-gtk2/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp
  head/www/webkit-gtk2/files/patch-Source_WebCore_plugins_PluginDatabase.cpp