Bug 212909 - www/squid: Update to 3.5.21
Summary: www/squid: Update to 3.5.21
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL:
Keywords: easy, patch
: 214429 (view as bug list)
Depends on:
Blocks: 212343
  Show dependency treegraph
 
Reported: 2016-09-22 20:11 UTC by ncrogers
Modified: 2016-11-24 12:39 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (timp87)


Attachments
port patch (1.00 KB, patch)
2016-09-23 07:06 UTC, timp87
timp87: maintainer-approval+
Details | Diff
port patch 2 (3.04 KB, patch)
2016-09-27 09:51 UTC, timp87
timp87: maintainer-approval+
Details | Diff
squid-3.5.22.patch (1.08 KB, patch)
2016-10-11 05:39 UTC, timp87
timp87: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ncrogers 2016-09-22 20:11:34 UTC
Squid 3.5.21 was released about 10 days ago.

http://squid-web-proxy-cache.1019090.n4.nabble.com/squid-announce-Squid-3-5-21-is-available-td4679447.html

I see the 4.x devel port has been updated. I am wondering if the maintainer plans on continuing to support 3.x or not?
Comment 1 timp87 2016-09-23 07:06:14 UTC
Created attachment 175081 [details]
port patch
Comment 2 timp87 2016-09-23 07:07:54 UTC
(In reply to ncrogers from comment #0)
I plan to support squid 3.x
I suppose we will move it to www/squid3 when squid 4.x is released (i. e. www/squid-devel -> www/squid)
Comment 3 timp87 2016-09-27 09:51:59 UTC
Created attachment 175194 [details]
port patch 2

This patch updates squid to latest 3.5.21 version and also includes all available fixes.
This fixes compilation with clang 3.9
Comment 4 timp87 2016-10-11 05:39:48 UTC
Created attachment 175611 [details]
squid-3.5.22.patch

Update 3.5.20 -> 3.5.22.
It includes clang 3.9 compilation fix.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-11-12 08:00:57 UTC
*** Bug 214429 has been marked as a duplicate of this bug. ***
Comment 6 commit-hook freebsd_committer 2016-11-24 12:39:12 UTC
A commit references this bug:

Author: amdmi3
Date: Thu Nov 24 12:39:08 UTC 2016
New revision: 427008
URL: https://svnweb.freebsd.org/changeset/ports/427008

Log:
  - Update to 3.5.22
  - Switch to options helpers

  PR:		212909
  Submitted by:	timp87@gmail.com (maintainer)

Changes:
  head/www/squid/Makefile
  head/www/squid/distinfo