Bug 213009 - www/py-django-contrib-comments : update to 1.7.3
Summary: www/py-django-contrib-comments : update to 1.7.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2016-09-26 18:25 UTC by Rene Ladan
Modified: 2016-12-06 04:58 UTC (History)
0 users

See Also:
koobs: maintainer-feedback+


Attachments
update py-django-contrib-comments (1.12 KB, patch)
2016-09-26 18:25 UTC, Rene Ladan
rene: maintainer-approval?
Details | Diff
output of 'make test' (1.18 KB, text/plain)
2016-09-26 18:28 UTC, Rene Ladan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Ladan freebsd_committer 2016-09-26 18:25:23 UTC
Created attachment 175184 [details]
update py-django-contrib-comments

Update www/py-django-contrib-comments to version 1.7.3 which is required for the upcoming Pootle 2.8

Also update the requested Django version from 1.6 to 1.8, as the former is unsupported. 'make test' still runs fine (see attachment)
Comment 1 Rene Ladan freebsd_committer 2016-09-26 18:28:15 UTC
Created attachment 175185 [details]
output of 'make test'
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-09-27 06:12:26 UTC
Approved to assign/commit if it passed QA (portlint, poudriere), the latter particularly because certain django dependency combinations can cause conflicts.
Comment 3 commit-hook freebsd_committer 2016-09-30 21:14:01 UTC
A commit references this bug:

Author: rene
Date: Fri Sep 30 21:13:21 UTC 2016
New revision: 423024
URL: https://svnweb.freebsd.org/changeset/ports/423024

Log:
  - Update to 1.7.3
  - Switch to django 1.8

  PR:		213009
  Submitted by:	myself
  Approved by:	maintainer (koobs)

Changes:
  head/www/py-django-contrib-comments/Makefile
  head/www/py-django-contrib-comments/distinfo
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2016-10-25 08:36:08 UTC
Assign to committer that resolved
Comment 5 commit-hook freebsd_committer 2016-12-04 10:48:48 UTC
A commit references this bug:

Author: koobs
Date: Sun Dec  4 10:48:34 UTC 2016
New revision: 427770
URL: https://svnweb.freebsd.org/changeset/ports/427770

Log:
  www/py-django-mezzanine-filebrowser: Update to 0.4.6

  - Update PORTVERSION and distinfo checksum (0.4.6)
  - Add NO_ARCH
  - Enable concurrent installation

  This update is 1 of 2 that are required to update
  www/py-django-mezzanine to a version that supports
  Django 1.8.

  This is required so that the port can be marked Un'BROKEN on head [1]
  and fixed in quarterly.

  The conflict caused by a change made in r423024 [2][3] that updated a
  dependency (contrib-comments) to use Django 1.8 which caused a
  CONFLICT (Django 1.6 / Django 1.8):

  pkg-static: py27-django18-1.8.16 conflicts with py27-django16-1.6.11 (installs files into the same place).  Problematic file: /usr/local/man/man1/django-admin.1.gz

  Failed to install the following 1 package(s): /packages/All/py27-django-contrib-comments-1.7.3.txz

  [1] https://svnweb.freebsd.org/changeset/ports/424630
  [2] https://svnweb.freebsd.org/changeset/ports/423024

  PR: 213009 [3]

  MFH:		2016Q4

Changes:
  head/www/py-django-mezzanine-filebrowser/Makefile
  head/www/py-django-mezzanine-filebrowser/distinfo
Comment 6 commit-hook freebsd_committer 2016-12-04 10:52:53 UTC
A commit references this bug:

Author: koobs
Date: Sun Dec  4 10:52:00 UTC 2016
New revision: 427772
URL: https://svnweb.freebsd.org/changeset/ports/427772

Log:
  www/py-django-mezzanine-grappelli: Update to 0.4.5

  - Update PORTVERSION and distinfo checksum (0.4.5)
  - Add NO_ARCH
  - Enable concurrent installation

  This update is 2 of 2 that are required to update
  www/py-django-mezzanine to a version that supports
  Django 1.8.

  This is required so that the port can be marked Un'BROKEN on head [1]
  and fixed in quarterly.

  The conflict caused by a change made in r423024 [2][3] that updated a
  dependency (contrib-comments) to use Django 1.8 which caused a
  CONFLICT (Django 1.6 / Django 1.8):

  pkg-static: py27-django18-1.8.16 conflicts with py27-django16-1.6.11 (installs files into the same place).  Problematic file: /usr/local/man/man1/django-admin.1.gz

  Failed to install the following 1 package(s): /packages/All/py27-django-contrib-comments-1.7.3.txz

  [1] https://svnweb.freebsd.org/changeset/ports/424630
  [2] https://svnweb.freebsd.org/changeset/ports/423024

  PR:	213009 [3]
  MFH:	2016Q4

Changes:
  head/www/py-django-mezzanine-grappelli/Makefile
  head/www/py-django-mezzanine-grappelli/distinfo
Comment 7 commit-hook freebsd_committer 2016-12-06 04:57:55 UTC
A commit references this bug:

Author: koobs
Date: Tue Dec  6 04:57:13 UTC 2016
New revision: 427931
URL: https://svnweb.freebsd.org/changeset/ports/427931

Log:
  MFH: r427770 www/py-django-mezzanine-filebrowser: Update to 0.4.6

  - Update PORTVERSION and distinfo checksum (0.4.6)
  - Add NO_ARCH
  - Enable concurrent installation

  This update is 1 of 2 that are required to update
  www/py-django-mezzanine to a version that supports
  Django 1.8.

  This is required so that the port can be marked Un'BROKEN on head [1]
  and fixed in quarterly.

  The conflict caused by a change made in r423024 [2][3] that updated a
  dependency (contrib-comments) to use Django 1.8 which caused a
  CONFLICT (Django 1.6 / Django 1.8):

  pkg-static: py27-django18-1.8.16 conflicts with py27-django16-1.6.11 (installs files into the same place).  Problematic file: /usr/local/man/man1/django-admin.1.gz

  Failed to install the following 1 package(s): /packages/All/py27-django-contrib-comments-1.7.3.txz

  [1] https://svnweb.freebsd.org/changeset/ports/424630
  [2] https://svnweb.freebsd.org/changeset/ports/423024

  PR: 213009 [3]

  Approved by:	ports-secteam (junovich, feld)

Changes:
_U  branches/2016Q4/
  branches/2016Q4/www/py-django-mezzanine-filebrowser/Makefile
  branches/2016Q4/www/py-django-mezzanine-filebrowser/distinfo
Comment 8 commit-hook freebsd_committer 2016-12-06 04:58:58 UTC
A commit references this bug:

Author: koobs
Date: Tue Dec  6 04:58:44 UTC 2016
New revision: 427932
URL: https://svnweb.freebsd.org/changeset/ports/427932

Log:
  MFH: r427772 www/py-django-mezzanine-grappelli: Update to 0.4.5

  - Update PORTVERSION and distinfo checksum (0.4.5)
  - Add NO_ARCH
  - Enable concurrent installation

  This update is 2 of 2 that are required to update
  www/py-django-mezzanine to a version that supports
  Django 1.8.

  This is required so that the port can be marked Un'BROKEN on head [1]
  and fixed in quarterly.

  The conflict caused by a change made in r423024 [2][3] that updated a
  dependency (contrib-comments) to use Django 1.8 which caused a
  CONFLICT (Django 1.6 / Django 1.8):

  pkg-static: py27-django18-1.8.16 conflicts with py27-django16-1.6.11 (installs files into the same place).  Problematic file: /usr/local/man/man1/django-admin.1.gz

  Failed to install the following 1 package(s): /packages/All/py27-django-contrib-comments-1.7.3.txz

  [1] https://svnweb.freebsd.org/changeset/ports/424630
  [2] https://svnweb.freebsd.org/changeset/ports/423024

  PR:	213009 [3]

  Approved by:	ports-secteam (junovich, feld)

Changes:
_U  branches/2016Q4/
  branches/2016Q4/www/py-django-mezzanine-grappelli/Makefile
  branches/2016Q4/www/py-django-mezzanine-grappelli/distinfo