Bug 213127 - www/redmine fails to start after revision 422934 (fix ldap option)
Summary: www/redmine fails to start after revision 422934 (fix ldap option)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ruby mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-30 17:33 UTC by Dušan Vejnovič
Modified: 2017-01-03 18:26 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (ruby)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dušan Vejnovič 2016-09-30 17:33:39 UTC
Redmine won't start after removing ldap option from Gemfile because it complains that can not find net/ldap file. When added ldap option back to Gemfile redmine starts normally.
Comment 1 Miroslav Lachman 2016-10-04 10:31:14 UTC
"Me too".

I upgraded redmine 3.2.3 -> 3.2.3_1 and it can't start until I remove 
/usr/local/www/redmine/app/models/auth_source_ldap.rb

I have this options in poudriere

# This file is auto-generated by 'make config'.
# Options for redmine-3.2.3
_OPTIONS_READ=redmine-3.2.3
_FILE_COMPLETE_OPTIONS_LIST=MYSQL POSTGRESQL LDAP MARKDOWN RMAGIC THIN PASSENGER
OPTIONS_FILE_SET+=MYSQL
OPTIONS_FILE_UNSET+=POSTGRESQL
OPTIONS_FILE_UNSET+=LDAP
OPTIONS_FILE_SET+=MARKDOWN
OPTIONS_FILE_SET+=RMAGIC
OPTIONS_FILE_SET+=THIN
OPTIONS_FILE_UNSET+=PASSENGER


www/redmine/Gemfile does not contain net-ldap


# ll /usr/local/www/redmine/bundler.d/
total 16
-rw-r--r--  1 root  wheel    28B Sep 30 12:53 markdown.rb
-rw-r--r--  1 root  wheel    26B Sep 30 12:53 mysql.rb
-rw-r--r--  1 root  wheel    27B Sep 30 12:53 rmagic.rb
-rw-r--r--  1 root  wheel    23B Sep 30 12:53 thin.rb


# uname -srmi
FreeBSD 10.3-RELEASE-p9 amd64 GENERIC


How can I disable loading of auth_source_ldap.rb instead of deleting it? Should this file be installed at all?
Comment 2 Matthew Seaman freebsd_committer 2016-10-05 09:13:04 UTC
Is this the same problem as PR 211276 ?
Comment 3 Miroslav Lachman 2016-10-05 09:29:11 UTC
(In reply to Matthew Seaman from comment #2)

I think this is different. Mark Felder reported problem with Redmine where net-ldap gem was installed but was defined twice - in Gemfile and in bundler.d directory.

Mine Redmine has not dependency on rubygem-net-ldap (is not installed), Gemfile has not net-ldap and bundler.d does not name it too. 
This Redmine instance should not use net-ldap but it still complains that net-ldap is missing.
Comment 4 Matthew Seaman freebsd_committer 2016-10-05 09:50:54 UTC
Ah -- seems 213085 was a duplicate of 211276, but that's already been fixed.  This is a different bug introduced after committing the fix in 213085.  211276 should probably be closed.
Comment 5 olevole 2016-10-23 17:45:39 UTC
me too: +1 another broken Redmine installation on FBSD
Comment 6 commit-hook freebsd_committer 2017-01-03 05:07:29 UTC
A commit references this bug:

Author: swills
Date: Tue Jan  3 05:06:34 UTC 2017
New revision: 430439
URL: https://svnweb.freebsd.org/changeset/ports/430439

Log:
  www/redmine: fix with newer gems

  Fix with newer ldap and mysql.

  PR:		213127

Changes:
  head/www/redmine/Makefile
  head/www/redmine/files/mysql.rb
  head/www/redmine/files/patch-Gemfile
Comment 7 Steve Wills freebsd_committer 2017-01-03 05:10:47 UTC
I think this is fixed now, I was able to reproduce the error and it seems fixed after this commit. Please test and let me know if not. Closing for now, reopen if there it's still an issue.
Comment 8 commit-hook freebsd_committer 2017-01-03 18:26:44 UTC
A commit references this bug:

Author: swills
Date: Tue Jan  3 18:25:45 UTC 2017
New revision: 430493
URL: https://svnweb.freebsd.org/changeset/ports/430493

Log:
  MFH multiple fixes to get redmine working

  MFH: r430437 r430439 r430440

  mail/rubygem-roadie: fix with newer nokogiri

  www/redmine: fix with newer gems

  Fix with newer ldap and mysql.

  PR:		213127

  www/redmine: fix startup when using thing

  PR:		213051
  Submitted by:	Matthias Fechner <idefix@fechner.net>

Changes:
_U  branches/2017Q1/
  branches/2017Q1/mail/rubygem-roadie/Makefile
  branches/2017Q1/mail/rubygem-roadie/files/
  branches/2017Q1/www/redmine/Makefile
  branches/2017Q1/www/redmine/files/mysql.rb
  branches/2017Q1/www/redmine/files/patch-Gemfile
  branches/2017Q1/www/redmine/files/redmine.in