Bug 213150 - net/tigervnc can't locate mcookie
Summary: net/tigervnc can't locate mcookie
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: John Marino
URL:
Keywords:
: 213607 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-02 02:25 UTC by Zane C. Bowers-Hadley
Modified: 2016-10-20 01:35 UTC (History)
4 users (show)

See Also:
meta: maintainer-feedback+


Attachments
mcookie (78 bytes, application/x-shellscript)
2016-10-03 03:29 UTC, Koichiro Iwao
no flags Details
patch (5.22 KB, patch)
2016-10-04 05:05 UTC, Koichiro Iwao
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zane C. Bowers-Hadley 2016-10-02 02:25:11 UTC
Attempting to run tigervnc 1.7.0 results in the item below.

[kitsune@vixen42]/home/kitsune% vncserver :2
vncserver: couldn't find "mcookie" on your PATH.
Exit 2
Comment 1 Koichiro Iwao freebsd_committer 2016-10-03 03:29:35 UTC
Created attachment 175381 [details]
mcookie

mcookie is a command of util-linux.  FreeBSD doesn't have it.
Quick workaround is put the attached shell script named mcookie into your PATH.

I'll report this to upstream. Please be patient.
Comment 2 Koichiro Iwao freebsd_committer 2016-10-04 05:05:45 UTC
Created attachment 175406 [details]
patch

I've submitted a patch to vncserver script.

tigervnc port requires mcookie command but mcookie is a part of util-linux.
Now vncserver script generates magic cookie without mcookie command.

The patch contains the same changes to both tigervnc and tigervnc-devel.
And one trivial change only to tigervnc (pkg-plist).



net/tigervnc, net/tigervnc-devel:
- generate magic cookie without cookie command

net/tigervnc:
- fix pkg-plist (Vietnamiese translation)
Comment 3 Koichiro Iwao freebsd_committer 2016-10-04 05:10:24 UTC
And strip binaries for both port.
Comment 4 Koichiro Iwao freebsd_committer 2016-10-04 05:15:21 UTC
(In reply to Koichiro IWAO from comment #2)

Fix typo in summary. I think this should be applied to quarterly.

net/tigervnc, net/tigervnc-devel:
- generate magic cookie without mcookie command
- strip binaries

net/tigervnc:
- fix pkg-plist (Vietnamiese translation)
Comment 5 commit-hook freebsd_committer 2016-10-05 15:38:50 UTC
A commit references this bug:

Author: marino
Date: Wed Oct  5 15:38:17 UTC 2016
New revision: 423352
URL: https://svnweb.freebsd.org/changeset/ports/423352

Log:
  net/tigervnc(-devel): runtime and stage-QA fix

  Previous attempts to run tigervnc resulted in the server quitting:
    vncserver: couldn't find "mcookie" on your PATH

  With the attached patch, the vncserver now generates the "magic cookie".
  While here, add the missing vietnamese translation to fix stage-QA checks.
  The -devel version got the same fix and was revbumped even though it is
  still ignored since it's no newer than the stable version.

  PR:		213150
  Reported by:	Zane Bowers-Hadley (vvelox [at] vvelox.net)
  Submitted by:	maintainer

Changes:
  head/net/tigervnc/Makefile
  head/net/tigervnc/files/patch-unix_vncserver
  head/net/tigervnc/pkg-plist
  head/net/tigervnc-devel/Makefile
  head/net/tigervnc-devel/files/patch-unix_vncserver
  head/net/tigervnc-devel/pkg-plist
Comment 6 John Marino freebsd_committer 2016-10-05 15:40:05 UTC
Done.
I went ahead and fixed the tignervnc-devel pkg-plist as well.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2016-10-20 01:35:11 UTC
*** Bug 213607 has been marked as a duplicate of this bug. ***