Bug 213169 - [NEW PORT] devel/serd: C library for RDF syntax
Summary: [NEW PORT] devel/serd: C library for RDF syntax
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
: 213286 (view as bug list)
Depends on:
Blocks: 213287 213288 213290
  Show dependency treegraph
 
Reported: 2016-10-03 10:40 UTC by Goran Mekić
Modified: 2018-01-19 11:28 UTC (History)
4 users (show)

See Also:


Attachments
shar file (2.28 KB, text/plain)
2016-10-03 10:40 UTC, Goran Mekić
no flags Details
Shar file for 0.24.0 version (2.28 KB, text/plain)
2016-10-03 18:00 UTC, Goran Mekić
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2016-10-03 10:40:18 UTC
Created attachment 175383 [details]
shar file

Serd is C library for RDF syntax.

It is used by some audio programs (new ardour, for example)
Comment 1 Goran Mekić 2016-10-03 18:00:44 UTC
Created attachment 175392 [details]
Shar file for 0.24.0 version

Initially, I've put 0.22.0 version, but there is newer.
Comment 2 Olivier Duchateau freebsd_committer 2016-10-08 19:34:12 UTC
*** Bug 213286 has been marked as a duplicate of this bug. ***
Comment 3 Kurt Jaeger freebsd_committer 2017-01-09 19:53:57 UTC
Testbuilds are fine, committed, thanks!
Comment 4 commit-hook freebsd_committer 2017-01-09 19:54:37 UTC
A commit references this bug:

Author: pi
Date: Mon Jan  9 19:53:38 UTC 2017
New revision: 431027
URL: https://svnweb.freebsd.org/changeset/ports/431027

Log:
  New port: devel/serd

  Serd is a lightweight C library for RDF syntax which supports reading
  and writing Turtle and NTriples.

  Serd (and the included serdi tool) can be used to stream abbreviated
  Turtle. Serd can serialise an unbounded amount of abbreviated
  Turtle using a fixed amount of memory, and it does so very quickly.

  Serd is written to the Turtle, NTriples and URI specifications, and
  includes a comprehensive test suite which includes all the tests
  from the Turtle specification.

  WWW: https://drobilla.net/software/serd

  PR:		213169
  Submitted by:	Goran Mekic <meka@tilda.center>

Changes:
  head/devel/Makefile
  head/devel/serd/
  head/devel/serd/Makefile
  head/devel/serd/distinfo
  head/devel/serd/pkg-descr
  head/devel/serd/pkg-plist
Comment 5 Felix Menders 2018-01-19 08:57:55 UTC
How can I use it for audio programs? Found it on https://github.com/drobilla/serd but still can't find the programs list. I'm planning to update my guide on http://essaywriting.ninja in the section "C library for RDF syntax".
Comment 6 Goran Mekić 2018-01-19 11:28:53 UTC
I'm not sure how to use it as I ported it because audio/ardour5 requires it. Maybe best approach is to check out how ardour5 uses it?