Bug 213242 - net-mgmt/zabbix2 (server/agent/proxy): Update to 2.0.20
Summary: net-mgmt/zabbix2 (server/agent/proxy): Update to 2.0.20
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Danilo Egea Gondolfo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-06 12:30 UTC by pg
Modified: 2017-02-08 22:06 UTC (History)
3 users (show)

See Also:


Attachments
patch to 2.0.19 (1.12 KB, patch)
2016-10-06 12:30 UTC, pg
no flags Details | Diff
patch to 2.0.20 (1.83 KB, patch)
2017-02-07 12:40 UTC, pg
pg: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pg 2016-10-06 12:30:01 UTC
Created attachment 175464 [details]
patch to 2.0.19

Zabbix 2.0.19 are now relesed
Comment 1 pg 2016-10-07 08:20:27 UTC
poudriere logs:
tail zabbix2-*-2.0.19*
==> zabbix2-agent-2.0.19_1.log <==
Installed packages to be REMOVED:
        zabbix2-agent-2.0.19_1

Number of packages to be removed: 1
[10amd64-local] [1/1] Deinstalling zabbix2-agent-2.0.19_1...
[10amd64-local] [1/1] Deleting files for zabbix2-agent-2.0.19_1: .......... done
==> You should manually remove the "zabbix" user. 
==> You should manually remove the "zabbix" group 
build of net-mgmt/zabbix2-agent ended at Fri Oct  7 11:17:23 MSK 2016
build time: 00:00:17

==> zabbix2-frontend-2.0.19.log <==
Installed packages to be REMOVED:
        zabbix2-frontend-2.0.19

Number of packages to be removed: 1

The operation will free 23 MiB.
[10amd64-local] [1/1] Deinstalling zabbix2-frontend-2.0.19...
[10amd64-local] [1/1] Deleting files for zabbix2-frontend-2.0.19: .......... done
build of net-mgmt/zabbix2-frontend ended at Thu Oct  6 15:20:55 MSK 2016
build time: 00:00:36

==> zabbix2-proxy-2.0.19.log <==

Number of packages to be removed: 1

The operation will free 13 MiB.
[10amd64-local] [1/1] Deinstalling zabbix2-proxy-2.0.19...
[10amd64-local] [1/1] Deleting files for zabbix2-proxy-2.0.19: .......... done
==> You should manually remove the "zabbix" user. 
==> You should manually remove the "zabbix" group 
build of net-mgmt/zabbix2-proxy ended at Thu Oct  6 15:02:32 MSK 2016
build time: 00:00:48

==> zabbix2-server-2.0.19.log <==

Number of packages to be removed: 1

The operation will free 13 MiB.
[10amd64-local] [1/1] Deinstalling zabbix2-server-2.0.19...
[10amd64-local] [1/1] Deleting files for zabbix2-server-2.0.19: .......... done
==> You should manually remove the "zabbix" user. 
==> You should manually remove the "zabbix" group 
build of net-mgmt/zabbix2-server ended at Thu Oct  6 15:04:13 MSK 2016
build time: 00:00:41
Comment 2 Pawel Pekala freebsd_committer 2016-10-11 19:15:06 UTC
+MYSQL_USES+=	mysql
+PGSQL_USES+=	pgsql
+SQLITE_USES+=	sqlite:3

No need for += here, this helper concatenates to USES by design.

Build fails when IODBC=on:
http://people.freebsd.org/~pawel/buildlogs/zabbix2-server-2.0.19-9amd64.log

Build fails when ORACLE=on:
http://people.freebsd.org/~pawel/buildlogs/zabbix2-server-2.0.19-10amd64.log
Comment 3 Pawel Pekala freebsd_committer 2016-12-05 20:45:10 UTC
No response in long while.
Comment 4 pg 2016-12-05 20:55:48 UTC
Sorry, tomorrow I'll look it.
Comment 5 pg 2017-02-07 12:40:04 UTC
Created attachment 179703 [details]
patch to 2.0.20

Zabbix 2.0.20 are now relesed
Comment 6 commit-hook freebsd_committer 2017-02-08 00:54:48 UTC
A commit references this bug:

Author: danilo
Date: Wed Feb  8 00:54:31 UTC 2017
New revision: 433629
URL: https://svnweb.freebsd.org/changeset/ports/433629

Log:
  - Update to 2.0.20

  PR:		213242
  Submitted by:	pg@pakhom.spb.ru

Changes:
  head/net-mgmt/zabbix2-server/Makefile
  head/net-mgmt/zabbix2-server/distinfo
  head/net-mgmt/zabbix2-server/files/patch-configure
Comment 7 Danilo Egea Gondolfo freebsd_committer 2017-02-08 22:06:50 UTC
Committed, thanks!