Bug 213283 - net/intel-ixl-kmod: do not set BROKEN et al for slave ports
Summary: net/intel-ixl-kmod: do not set BROKEN et al for slave ports
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-07 19:38 UTC by Franco Fichtner
Modified: 2016-10-13 19:34 UTC (History)
4 users (show)

See Also:
skozlov: maintainer-feedback+


Attachments
ixl port patch (1.14 KB, patch)
2016-10-07 19:38 UTC, Franco Fichtner
franco: maintainer-approval? (franco)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Franco Fichtner 2016-10-07 19:38:47 UTC
Created attachment 175508 [details]
ixl port patch

Hi Sergey,

Here is the patch that works for me.  Feel free to modify.  I don't know the build parameters of em(4), but i386 works fine (on 11.0 as well).


Cheers,
Franco
Comment 1 Bugzilla Automation freebsd_committer 2016-10-07 19:38:47 UTC
Maintainer informed via mail
Comment 2 Sean Bruno freebsd_committer 2016-10-07 19:44:24 UTC
Ok, thanks.  I'll commit this when Sergey gets a chance to look at it.
Comment 3 Serhii (Sergey) Kozlov freebsd_committer 2016-10-10 16:02:26 UTC
Comment on attachment 175508 [details]
ixl port patch

The patch looks OK for me.
Comment 4 commit-hook freebsd_committer 2016-10-13 19:31:52 UTC
A commit references this bug:

Author: sbruno
Date: Thu Oct 13 19:31:06 UTC 2016
New revision: 423932
URL: https://svnweb.freebsd.org/changeset/ports/423932

Log:
  Do not set BROKEN for slave ports.

  PR:	213283
  Submitted by:	Franco Fichtner <franco@opnsense.org>
  Reviewed by:	Sergey Kozlov <kozlov.sergey.404@gmail.com>

Changes:
  head/net/intel-ixl-kmod/Makefile
Comment 5 Sean Bruno freebsd_committer 2016-10-13 19:34:46 UTC
Reminded about this during our Intel Community conference call, all done.