Bug 213405 - [patch] lang/fsharp: fix build
Summary: [patch] lang/fsharp: fix build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: David Naylor
URL:
Keywords: patch
: 202620 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-12 06:35 UTC by David Naylor
Modified: 2016-10-14 20:52 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (mono)


Attachments
Fix for lang/fsharp, new port: lang/referenceassemblies-pcl (93.19 KB, patch)
2016-10-12 06:35 UTC, David Naylor
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Naylor freebsd_committer 2016-10-12 06:35:00 UTC
Created attachment 175649 [details]
Fix for lang/fsharp, new port: lang/referenceassemblies-pcl

Fix build if fsharp by:
 - adding PCL reference assemblies to port's tree
 - downloading and extracting the required nuget packages.

Tested with poudriere
Comment 1 David Naylor freebsd_committer 2016-10-14 15:35:31 UTC
Take, as I am now part of the mono team.
Comment 2 commit-hook freebsd_committer 2016-10-14 15:36:19 UTC
A commit references this bug:

Author: dbn
Date: Fri Oct 14 15:35:51 UTC 2016
New revision: 423977
URL: https://svnweb.freebsd.org/changeset/ports/423977

Log:
  lang/fsharp: fix build, add test support.

   - Use license file from source
   - Depend on PCL reference assemblies
   - Download and extract nuget packages
   - Mark the port as MAKE_JOBS_UNSAFE (it always run -j1)
   - Mark the port as architecture agnostic (intepreted by mono)
   - Add test support

  PR:		213405

Changes:
  head/lang/fsharp/Makefile
  head/lang/fsharp/distinfo
Comment 3 commit-hook freebsd_committer 2016-10-14 15:38:21 UTC
A commit references this bug:

Author: dbn
Date: Fri Oct 14 15:37:23 UTC 2016
New revision: 423978
URL: https://svnweb.freebsd.org/changeset/ports/423978

Log:
  lang/fsharp: add missing patch files

   - remove autorestore of nuget packages (now done by port)

  PR:		213405

Changes:
  head/lang/fsharp/files/
  head/lang/fsharp/files/patch-Makefile.in
  head/lang/fsharp/files/patch-src_FSharpSource.targets
Comment 4 David Naylor freebsd_committer 2016-10-14 15:39:24 UTC
*** Bug 202620 has been marked as a duplicate of this bug. ***
Comment 5 Romain Tartière freebsd_committer 2016-10-14 20:52:23 UTC
Thank you for managing this!