Bug 213442 - mail/opensmtpd: Update to 6.6.0
Summary: mail/opensmtpd: Update to 6.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dima Panov
URL: https://opensmtpd.org/announces/relea...
Keywords:
: 241404 (view as bug list)
Depends on:
Blocks: 228937
  Show dependency treegraph
 
Reported: 2016-10-13 10:52 UTC by Arkadiy
Modified: 2019-10-28 09:16 UTC (History)
20 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
Update Patch to 6.0.2p1 (2.00 KB, patch)
2016-11-29 23:50 UTC, Carlo Strub
koobs: maintainer-approval? (fluffy)
Details | Diff
OpenSMTPD 6.4.1p2 patch (4.00 KB, patch)
2019-03-28 07:17 UTC, Felix Hanley
no flags Details | Diff
OpenSMTPD 6.4.2p1 patch (with LibreSSL requirement) (5.46 KB, text/plain)
2019-10-22 01:19 UTC, Douglas Carmichael
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arkadiy 2016-10-13 10:52:18 UTC
Presently mail/opensmtpd port version is 5.9.2p1.
New stable release 6.0.1 was announces in October 03, 2016 (https://www.opensmtpd.org/).
Can somebody update port to the latest stable version?
Comment 1 Dima Panov freebsd_committer 2016-10-17 14:06:36 UTC
(In reply to Arkadiy from comment #0)

Just to be convinced: latest 6.0.x snapshots still not stable as they should be, runs only with certain functions disabled, like filter-api.

So please be patient before real stable version will be released, keep calm and be happy with current port and worked filters and other plugins.
Comment 2 Carlo Strub freebsd_committer 2016-11-29 23:50:48 UTC
Created attachment 177526 [details]
Update Patch to 6.0.2p1

Feel free to try that patch for 6.0.2p1
Comment 3 Dima Panov freebsd_committer 2016-11-30 09:29:21 UTC
(In reply to Carlo Strub from comment #2)

OpenSMTPd-6.0.2 still declared by author as not-ready-for-production, and filter-api is still missing, so update in portstree will be delayed until full-featured snapshot will be released. Please be patient, Gilles promised it will happens soon.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2017-10-29 02:21:32 UTC
Issue metadata has not been updated to reflect its current state.

- ashish is not current maintainer
- proposed patch is for an update (update summary)
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2017-10-29 02:22:09 UTC
Comment on attachment 177526 [details]
Update Patch to 6.0.2p1

'Reset' maintainer timeout timer. (it has been a year)
Comment 6 Dima Panov freebsd_committer 2017-11-08 13:41:32 UTC
Folks, please be patient. 6.0.2 broke all filters due to new, unstable API.
We all waiting 6.1 release, which promised to be landed this winter, with new-new API subdaemons for plugins/filters
Comment 7 Carlo Strub freebsd_committer 2018-01-25 22:13:00 UTC
Anyone tried https://www.opensmtpd.org/announces/release-6.0.3.txt ?

Not sure if the filter issues are gone...
Comment 8 Dima Panov freebsd_committer 2018-01-26 08:44:55 UTC
(In reply to Carlo Strub from comment #7)
6.0.3 still provide -devel API without filters, which should come along with 6.1 release
Comment 9 Rudolph 2018-10-24 07:00:57 UTC
With the release of OpenBSD 6.4 we now also have OpenSMTPD 6.4. This might be the time to update this port?
Comment 10 Christoph Lukas 2018-10-24 14:47:21 UTC
(In reply to Rudolph from comment #9)
The portable version of OpenSMTPD 6.4 has not been released yet.
That should happen "in the next few days", as per this status update:
https://twitter.com/OpenSMTPD/status/1054830259676344321
Comment 11 Dima Panov freebsd_committer 2018-10-25 00:13:34 UTC
Folks, keep calm. 6.4 release will be public in next days, but we have a problem — no more openssl support, only libressl :(
Comment 12 Martin Rehak 2018-12-17 20:35:21 UTC
After upgrade to FreeBSD 12.0 I have found that there is no opensmtpd package at all. Port 5.9.2p1 still exists, but can't be built. Is there ANY workaround or a way how to build/install whichever version, please? Otherwise this issue seems as a show stopper for people who would like to upgrade to 12.
Comment 13 wcarson.bugzilla 2018-12-17 20:46:06 UTC
(In reply to Martin Rehak from comment #12)

According to bug #228937, comment #4 it's due to the OpenSSL 1.1 incompatibility and has been marked BROKEN. I build opensmtpd myself and use libressl, so I just commented out the #ifs and BROKEN= parts of the Makefile.
Comment 14 Alexander 2018-12-18 05:09:43 UTC
OpenSMTPD 6.4.1 released https://opensmtpd.org/announces/release-6.4.1.txt
Comment 15 hblanks 2019-03-02 23:55:37 UTC
Just wanted to point out that, in addition to moving to libressl, the opensmtpd 5.9.2p1 archives are no longer available for download. So, even with this fixed, you still can't install opensmtpd from ports on a fresh install. Should that be a separate issue?

FWIW, I was able to download opensmtpd-6.4.1p2, configure it with libressl, and compile and install it outside of the ports tree. But I'm not sure how to update the port files.
Comment 16 Felix Hanley 2019-03-28 07:17:17 UTC
Created attachment 203209 [details]
OpenSMTPD 6.4.1p2 patch

I have added a patch from the current svn revision to 6.4.1p2 with libressl built in. It seems to work for me with initial testing but other eyes welcome.
Comment 17 Dima Panov freebsd_committer 2019-03-28 13:03:56 UTC
(In reply to Felix Hanley from comment #16)

I've already tested the same idea. Unfortunately, it will always fail if libevent was compiled with system openssl.

A latest buildable with ssl'ed libevent version is still 6.0.3 :(
Comment 18 avatar4d 2019-04-01 15:50:00 UTC
I just upgraded to 12.0-RELEASE last week and since I was using opensmtpd am now missing my mailserver due to the problem mentioned in this bug. I see nothing in UPDATING that indicates this package would be unavailable in 12.0. Is there a centralized resource that someone could easily check before upgrading to know whether a situation like this exists? Or do I have to check every port I use against something like FreshPorts and if I find a port marked broken cross-reference the date that happened with the release date of an FreeBSD version upgrade and then check that a package is entirely missing in that repo? 

I would not have upgraded had I known I was going to missing this package. :-/
Comment 19 Carlo Strub freebsd_committer 2019-05-22 20:41:54 UTC
Did you try to build it on 12 with SSL_DEFAULT=libressl[-devel] in your make.conf?
Comment 20 Martin Rehak 2019-09-26 16:41:30 UTC
(In reply to Dima Panov from comment #17)

I have well working opensmtpd 6.4.2 compiled against libressl and libevent. What particular issue are you facing? Could I help?
Comment 21 Kubilay Kocak freebsd_committer freebsd_triage 2019-09-30 01:59:38 UTC
This issue needs the following to progress:

- A single patch updating the port to 6.4.2p1 (latest version at this time of writing)
- QA'd (with poudriere) against all DEFAULT_VERSIONS ssl values
Comment 22 Dima Panov freebsd_committer 2019-09-30 10:07:21 UTC
Folks, again - please be patient. 6.4.2 is not ready to be built agains any ssl version but libressl only. 
You can't build all with openssl than install libressl and build opensmtpd with libre — this will fail your setup at all when you try to build any ssl-related stuff.

Building with static libressl faced another BIG issue — our ssl framework is totally broken and messed up by design. Pure DLL hell in all-round with libssl.so/libcrypto.so. Try it! (https://people.freebsd.org/~fluffy/opensmtpd642.tar.xz) Our linker will check ssl function names via base libcrypro.so/libssl.so even while static stuff from libressl was proposed, so static build will fine at 12.x but fails at 11.x because openssll1x api.
 
Currently we have some future deals: 1) stash any ssl/crypto in base to private (but it still faced with open/libre mixups from ports). 2) after first step, do some magic with includes/libs rename to allow open and libre coexist as it was designed by libressl team 


BTW, 6.6 release will be released soon and it will be fully compatible with openssl11, so 12.x builds will be fine in any state.
Comment 23 Kubilay Kocak freebsd_committer freebsd_triage 2019-10-22 01:05:08 UTC
*** Bug 241404 has been marked as a duplicate of this bug. ***
Comment 24 Douglas Carmichael 2019-10-22 01:19:35 UTC
Created attachment 208496 [details]
OpenSMTPD 6.4.2p1 patch (with LibreSSL requirement)

This is an alternate OpenSMTPD 6.4.2p1 patch that requires the use of LibreSSL.
Comment 25 me 2019-10-22 05:59:06 UTC
opensmtpd 6.6 portable with its openssl support is pretty close to be released so may want to check that instead?

https://github.com/OpenSMTPD/OpenSMTPD/tree/branch-6.6.0p1
Comment 26 Dima Panov freebsd_committer 2019-10-22 07:47:03 UTC
(In reply to Douglas Carmichael from comment #24)
Sorry, pal, ur patch is wrong. You can't directly rely to libressl, this step will broke any ssl-related stuff which exist on same box. 

Our ssl framework is totally broken. 

6.6 portable release is almost here, but it will drop support for fbsd11.x with base ssl (only with open11 or libre by default)
Comment 27 Ben Woods freebsd_committer 2019-10-26 14:27:05 UTC
opensmtpd 6.6.0 was just released, and supports OpenSSL 1.1
https://opensmtpd.org/announces/release-6.6.0.txt
Comment 28 commit-hook freebsd_committer 2019-10-26 16:25:25 UTC
A commit references this bug:

Author: fluffy
Date: Sat Oct 26 16:24:54 UTC 2019
New revision: 515714
URL: https://svnweb.freebsd.org/changeset/ports/515714

Log:
  - Update OpenSMTPd to 6.6.0 portable release
      This release builds with LibreSSL > 3.0.2 or OpenSSL > 1.1.0.
      FreeBSD 11.x users should update to 12.x/13.x or switch system-wide
      default ssl library to openssl111/libressl

  - Update -extras to 6.4.0 release
      Filters still missing, corresponded ports temporary markes
      as IGNORED

  PR:		213442,228937
  MFH:		2019Q4

Changes:
  head/mail/opensmtpd/Makefile
  head/mail/opensmtpd/distinfo
  head/mail/opensmtpd/files/patch-mk_smtpd_Makefile.in
  head/mail/opensmtpd/files/patch-smtpd-rfc2822.c
  head/mail/opensmtpd/files/patch-smtpd-smtp_session.c
  head/mail/opensmtpd/files/patch-src_mda.c
  head/mail/opensmtpd/files/pkg-message.in
  head/mail/opensmtpd/pkg-plist
  head/mail/opensmtpd-extras/Makefile
  head/mail/opensmtpd-extras/distinfo
  head/mail/opensmtpd-extras-filter-clamav/Makefile
  head/mail/opensmtpd-extras-filter-dkim/Makefile
  head/mail/opensmtpd-extras-filter-dnsbl/Makefile
  head/mail/opensmtpd-extras-filter-lua/Makefile
  head/mail/opensmtpd-extras-filter-monkey/Makefile
  head/mail/opensmtpd-extras-filter-pause/Makefile
  head/mail/opensmtpd-extras-filter-perl/Makefile
  head/mail/opensmtpd-extras-filter-python/Makefile
  head/mail/opensmtpd-extras-filter-regex/Makefile
  head/mail/opensmtpd-extras-filter-spamassassin/Makefile
  head/mail/opensmtpd-extras-queue-python/Makefile
  head/mail/opensmtpd-extras-queue-ram/Makefile
  head/mail/opensmtpd-extras-scheduler-python/Makefile
  head/mail/opensmtpd-extras-scheduler-ram/Makefile
  head/mail/opensmtpd-extras-table-ldap/Makefile
  head/mail/opensmtpd-extras-table-mysql/Makefile
  head/mail/opensmtpd-extras-table-passwd/Makefile
  head/mail/opensmtpd-extras-table-postgresql/Makefile
  head/mail/opensmtpd-extras-table-python/Makefile
  head/mail/opensmtpd-extras-table-redis/Makefile
  head/mail/opensmtpd-extras-table-socketmap/Makefile
  head/mail/opensmtpd-extras-table-sqlite/Makefile
  head/mail/opensmtpd-extras-tool-stats/Makefile