Bug 213491 - gpt{,zfs}boot after r305353 crash in GELIBoot
Summary: gpt{,zfs}boot after r305353 crash in GELIBoot
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Many People
Assignee: Warner Losh
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-10-15 00:05 UTC by Allan Jude
Modified: 2017-07-19 09:58 UTC (History)
7 users (show)

See Also:


Attachments
screenshot of btx crash (6.92 KB, image/png)
2016-10-15 00:05 UTC, Allan Jude
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Allan Jude freebsd_committer 2016-10-15 00:05:09 UTC
Created attachment 175769 [details]
screenshot of btx crash

Since the LF_FLAGS change in r305353 both gptboot (ufs) and gptzfsboot crash when trying to read from encrypted disks.

The struct enc_xform_aes_xts is invalid, and contains invalid function pointers that are called

Reverting the linker flag changes resolves the problem.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2016-10-15 19:40:49 UTC
Over to committer of r305353.
Comment 2 Graham Perrin 2016-10-18 19:29:03 UTC
Thanks Allan. 

Reading this alongside <https://gitter.im/trueos/Lobby?at=57e1a8f8aabc89857fbb9ff7>

> clean installation to an old Ergo Vista 621

and <https://gitter.im/trueos/Lobby?at=580661062189c68f42fa9787>
Comment 3 Piotr 2016-10-20 14:45:33 UTC
I have the same problem. 
Fresh install of TrueOS on Latitutde E7220.

I get the error BTX Halted. I don't know how to fix it apart from reinstalling without GELI enabled.

http://i.imgur.com/fqcEpZu.jpg
Comment 4 dc 2016-11-15 20:05:12 UTC
I am able to reproduce this with GELI enabled. When disabling GELI, the issue no longer exists.
Comment 5 Allan Jude freebsd_committer 2016-11-15 20:10:31 UTC
(In reply to dc from comment #4)
What revision are you testing?

This should have been fixed by: r307954 https://svnweb.freebsd.org/base?view=revision&revision=307954