Bug 213498 - devel/libnotify: Update to 0.7.7
Summary: devel/libnotify: Update to 0.7.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords: patch-ready
: 180596 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-15 08:16 UTC by Olivier Duchateau
Modified: 2018-01-09 10:29 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
Patch to update devel/libnotify (7.75 KB, patch)
2016-10-15 08:16 UTC, Olivier Duchateau
no flags Details | Diff
Patch to update devel/libnotify (7.79 KB, patch)
2017-01-18 17:29 UTC, Olivier Duchateau
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau freebsd_committer 2016-10-15 08:16:04 UTC
Created attachment 175779 [details]
Patch to update devel/libnotify

- Update to 0.7.7
- Remove patches, replaced by CONFIGURE_ARGS+= --disable-tests
- Replace USES= gettext by USES= gettext-runtime
Comment 1 Tijl Coosemans freebsd_committer 2017-01-18 14:13:53 UTC
Can you include changes from bug 180596 (remove intlhack and change to instrospection:build) so that can be closed?
Comment 2 Olivier Duchateau freebsd_committer 2017-01-18 17:29:49 UTC
Created attachment 179040 [details]
Patch to update devel/libnotify

New patch, which removes intlhack and replace introspection by introspection:build.
Comment 3 Tijl Coosemans freebsd_committer 2017-01-18 17:46:02 UTC
*** Bug 180596 has been marked as a duplicate of this bug. ***
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-01-09 04:11:25 UTC
Makefile has 0.7.7, seems done.
Comment 5 commit-hook freebsd_committer 2018-01-09 10:25:41 UTC
A commit references this bug:

Author: tijl
Date: Tue Jan  9 10:25:24 UTC 2018
New revision: 458520
URL: https://svnweb.freebsd.org/changeset/ports/458520

Log:
  - There's no reference to gettext in the source code so remove USES=gettext
    and USE_GNOME=intlhack.
  - Also remove no longer needed USES=localbase and USES=pathfix.
  - Change USE_GNOME=introspection into a build dependency.

  PR:		213498
  Approved by:	maintainer timeout (1 year)

Changes:
  head/devel/libnotify/Makefile