Bug 213551 - lang/beignet: fix for utests compilation
Summary: lang/beignet: fix for utests compilation
Status: Closed DUPLICATE of bug 217771
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-17 00:50 UTC by Igor Pavlov
Modified: 2017-03-13 20:24 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
Patch for utests/image_from_buffer.cpp (697 bytes, patch)
2016-10-17 00:52 UTC, Igor Pavlov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Pavlov 2016-10-17 00:50:04 UTC
Proposed patch fixes utests/image_from_buffer.cpp file compilation.
Comment 1 Igor Pavlov 2016-10-17 00:52:29 UTC
Created attachment 175842 [details]
Patch for utests/image_from_buffer.cpp
Comment 2 Jan Beich freebsd_committer 2017-03-13 20:24:56 UTC
utests aren't built by default. Bug 217771 tries a bit harder to make them work but uses aligned_alloc (C11) to avoid POSIX weirdness.

  $ make clean test WITH=TEST BATCH=

*** This bug has been marked as a duplicate of bug 217771 ***