Bug 213667 - www/firefox: Shared object "libplc4.so.1" not found, required by "libssl3.so"
Summary: www/firefox: Shared object "libplc4.so.1" not found, required by "libssl3.so"
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2016-10-21 10:36 UTC by Julien Cigar
Modified: 2016-10-24 08:19 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Cigar 2016-10-21 10:36:34 UTC
It looks like there is some shared library bump issue, this is from a custom Poudriere repo with:

jcigar@frodon:~/ > pkg info firefox-49.0_8,1|more
firefox-49.0_8,1
Name           : firefox
Version        : 49.0_8,1
Installed on   : Fri Oct 21 12:16:41 2016 CEST
Origin         : www/firefox
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : ipv6 www
Licenses       : 
Maintainer     : gecko@FreeBSD.org
WWW            : http://www.mozilla.com/firefox
Comment        : Web browser based on the browser portion of Mozilla
Options        :
        ALSA           : on
        BUNDLED_CAIRO  : off
        CANBERRA       : off
        DBUS           : on
        DEBUG          : off
        DTRACE         : off
        FFMPEG         : on
        GCONF          : off
        GNOMEUI        : off
        GTK2           : off
        GTK3           : on
        INTEGER_SAMPLES: off
        LIBPROXY       : off
        OPTIMIZED_CFLAGS: on
        PGO            : off
        PROFILE        : off
        PULSEAUDIO     : off
        RUST           : on
        TEST           : off
Shared Libs required:
        libdbus-glib-1.so.2
        libgtk-x11-2.0.so.0
        libXext.so.6
        libpango-1.0.so.0
        libjpeg.so.8
        libpixman-1.so.0
        libsqlite3.so.0
        libicuuc.so.57
        libcairo.so.2
        libgtk-3.so.0
        libffi.so.6
        libfreetype.so.6
        libcairo-gobject.so.2
        libatk-1.0.so.0
        libXt.so.6
        libvpx.so.4
        libplc4.so
        libXcomposite.so.1
        libicui18n.so.57
        libgdk_pixbuf-2.0.so.0
        libgio-2.0.so.0
        libssl3.so
        libXfixes.so.3
        libnss3.so
        libogg.so.0
        libv4l2.so.0
        libgobject-2.0.so.0
        libnssutil3.so
        libplds4.so
        libharfbuzz.so.0
        libstartup-notification-1.so.0
        libX11.so.6
        libdbus-1.so.3
        libXdamage.so.1
        libnspr4.so
        libSoundTouch.so.1
        libgraphite2.so.3
        libglib-2.0.so.0
        libpng16.so.16
        libXrender.so.1
        libvorbis.so.0
        libevent-2.0.so.5
        libhunspell-1.3.so.0
        libfontconfig.so.1
        libsmime3.so
        libgdk-x11-2.0.so.0
        libgdk-3.so.0
Annotations    :
        cpe            : cpe:2.3:a:mozilla:firefox:49.0:::::freebsd10:x64:8
        no_provide_shlib: yes
        repo_type      : binary
        repository     : bebif
Flat size      : 99.1MiB
(...)
jcigar@frodon:~/ > firefox 
XPCOMGlueLoad error for file /usr/local/lib/firefox/libxul.so:
Shared object "libplc4.so.1" not found, required by "libssl3.so"
Couldn't load XPCOM.

jcigar@frodon:~/ > ldd /usr/local/bin/firefox 
/usr/local/bin/firefox:
        libc++.so.1 => /usr/lib/libc++.so.1 (0x801659000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x801918000)
        libm.so.5 => /lib/libm.so.5 (0x801b34000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x801d5d000)
        libthr.so.3 => /lib/libthr.so.3 (0x801f6b000)
        libc.so.7 => /lib/libc.so.7 (0x800821000)

jcigar@frodon:~/ > find /usr/local/lib -type f -iname "*libplc4*" 
/usr/local/lib/libplc4.a
/usr/local/lib/libplc4.so

jcigar@frodon:~/ > pkg which /usr/local/lib/libplc4.so
/usr/local/lib/libplc4.so was installed by package nspr-4.13_1
Comment 1 Julien Cigar 2016-10-21 10:39:38 UTC
.. and I forgot:

jcigar@frodon:~/ > ldd /usr/local/lib/firefox/libxul.so
/usr/local/lib/firefox/libxul.so:
        liblgpllibs.so => /usr/local/lib/firefox/liblgpllibs.so (0x805f69000)
        libmozgtk.so => /usr/local/lib/firefox/libmozgtk.so (0x8061f2000)
        libicui18n.so.57 => /usr/local/lib/libicui18n.so.57 (0x806400000)
        libicuuc.so.57 => /usr/local/lib/libicuuc.so.57 (0x80689b000)
        libffi.so.6 => /usr/local/lib/libffi.so.6 (0x806c48000)
        libplds4.so => /usr/local/lib/libplds4.so (0x806e4f000)
        libplc4.so => /usr/local/lib/libplc4.so (0x807052000)
        libnspr4.so => /usr/local/lib/libnspr4.so (0x807256000)
        libz.so.6 => /lib/libz.so.6 (0x807492000)
        libm.so.5 => /lib/libm.so.5 (0x8076a8000)
        libssl3.so => /usr/local/lib/firefox/libssl3.so (0x8078d1000)
        libsmime3.so => /usr/local/lib/firefox/libsmime3.so (0x807b0b000)
        libnss3.so => /usr/local/lib/firefox/libnss3.so (0x807d34000)
        libnssutil3.so => /usr/local/lib/firefox/libnssutil3.so (0x808056000)
        libsqlite3.so.0 => /usr/local/lib/libsqlite3.so.0 (0x808281000)
        libfreetype.so.6 => /usr/local/lib/libfreetype.so.6 (0x80855f000)
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0x808802000)
        libutil.so.9 => /lib/libutil.so.9 (0x808a47000)
        libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0x808c59000)
        libthr.so.3 => /lib/libthr.so.3 (0x808f6f000)
        libXext.so.6 => /usr/local/lib/libXext.so.6 (0x809193000)
        libXrender.so.1 => /usr/local/lib/libXrender.so.1 (0x8093a4000)
        libX11.so.6 => /usr/local/lib/libX11.so.6 (0x8095ad000)
        libv4l2.so.0 => /usr/local/lib/libv4l2.so.0 (0x8098e5000)
        libXdamage.so.1 => /usr/local/lib/libXdamage.so.1 (0x809af2000)
        libXfixes.so.3 => /usr/local/lib/libXfixes.so.3 (0x809cf4000)
        libXcomposite.so.1 => /usr/local/lib/libXcomposite.so.1 (0x809ef9000)
        libjpeg.so.8 => /usr/local/lib/libjpeg.so.8 (0x80a0fb000)
        libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0x80a366000)
        libhunspell-1.3.so.0 => /usr/local/lib/libhunspell-1.3.so.0 (0x80a59c000)
        libogg.so.0 => /usr/local/lib/libogg.so.0 (0x80a7ef000)
        libvorbis.so.0 => /usr/local/lib/libvorbis.so.0 (0x80a9f5000)
        libSoundTouch.so.1 => /usr/local/lib/libSoundTouch.so.1 (0x80ac22000)
        libevent-2.0.so.5 => /usr/local/lib/libevent-2.0.so.5 (0x80ae32000)
        libvpx.so.4 => /usr/local/lib/libvpx.so.4 (0x80b075000)
        libpixman-1.so.0 => /usr/local/lib/libpixman-1.so.0 (0x80b417000)
        libgraphite2.so.3 => /usr/local/lib/libgraphite2.so.3 (0x80b6bb000)
        libharfbuzz.so.0 => /usr/local/lib/libharfbuzz.so.0 (0x80b8ee000)
        libdbus-glib-1.so.2 => /usr/local/lib/libdbus-glib-1.so.2 (0x80bb46000)
        libdbus-1.so.3 => /usr/local/lib/libdbus-1.so.3 (0x80bd6c000)
        libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0x80bfc0000)
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x80c208000)
        libpango-1.0.so.0 => /usr/local/lib/libpango-1.0.so.0 (0x80c50e000)
        libatk-1.0.so.0 => /usr/local/lib/libatk-1.0.so.0 (0x80c75d000)
        libcairo-gobject.so.2 => /usr/local/lib/libcairo-gobject.so.2 (0x80c986000)
        libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0 (0x80cb8e000)
        libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0x80cdad000)
        libstartup-notification-1.so.0 => /usr/local/lib/libstartup-notification-1.so.0 (0x80d118000)
        libXt.so.6 => /usr/local/lib/libXt.so.6 (0x80d321000)
        libc++.so.1 => /usr/lib/libc++.so.1 (0x80d583000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x80d842000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x80da5e000)
        libc.so.7 => /lib/libc.so.7 (0x800821000)
        libgtk-3.so.0 => /usr/local/lib/libgtk-3.so.0 (0x80de00000)
        libgdk-3.so.0 => /usr/local/lib/libgdk-3.so.0 (0x80e69a000)
        libicudata.so.57 => /usr/local/lib/libicudata.so.57 (0x80e939000)
        libplc4.so.1 => not found (0)
        libplds4.so.1 => not found (0)
        libnspr4.so.1 => not found (0)
        libplc4.so.1 => not found (0)
        libplds4.so.1 => not found (0)
        libnspr4.so.1 => not found (0)
        libplc4.so.1 => not found (0)
        libplds4.so.1 => not found (0)
        libnspr4.so.1 => not found (0)
        libplc4.so.1 => not found (0)
        libplds4.so.1 => not found (0)
        libnspr4.so.1 => not found (0)
        libbz2.so.4 => /usr/lib/libbz2.so.4 (0x80eb3a000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0x80ed4c000)
        libEGL.so.1 => /usr/local/lib/libEGL.so.1 (0x80ef73000)
        libxcb-shm.so.0 => /usr/local/lib/libxcb-shm.so.0 (0x80f18f000)
        libxcb-render.so.0 => /usr/local/lib/libxcb-render.so.0 (0x80f391000)
        libxcb.so.1 => /usr/local/lib/libxcb.so.1 (0x80f59a000)
        libGL.so.1 => /usr/local/lib/libGL.so.1 (0x80f7b9000)
        libv4lconvert.so.0 => /usr/local/lib/libv4lconvert.so.0 (0x80fab5000)
        libintl.so.8 => /usr/local/lib/libintl.so.8 (0x80fd2c000)
        libiconv.so.2 => /usr/local/lib/libiconv.so.2 (0x80ff37000)
        libpcre.so.1 => /usr/local/lib/libpcre.so.1 (0x810231000)
        libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0x8104aa000)
        libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0x8106ab000)
        libxcb-util.so.1 => /usr/local/lib/libxcb-util.so.1 (0x8108ae000)
        libX11-xcb.so.1 => /usr/local/lib/libX11-xcb.so.1 (0x810ab3000)
        libSM.so.6 => /usr/local/lib/libSM.so.6 (0x810cb4000)
        libICE.so.6 => /usr/local/lib/libICE.so.6 (0x810ebb000)
        libXinerama.so.1 => /usr/local/lib/libXinerama.so.1 (0x8110d6000)
        libXrandr.so.2 => /usr/local/lib/libXrandr.so.2 (0x8112d8000)
        libXcursor.so.1 => /usr/local/lib/libXcursor.so.1 (0x8114e1000)
        librt.so.1 => /usr/lib/librt.so.1 (0x8116eb000)
        libpangocairo-1.0.so.0 => /usr/local/lib/libpangocairo-1.0.so.0 (0x8118f1000)
        libXi.so.6 => /usr/local/lib/libXi.so.6 (0x811afe000)
        libatk-bridge-2.0.so.0 => /usr/local/lib/libatk-bridge-2.0.so.0 (0x811d0c000)
        libepoxy.so.0 => /usr/local/lib/libepoxy.so.0 (0x811f3b000)
        libpangoft2-1.0.so.0 => /usr/local/lib/libpangoft2-1.0.so.0 (0x812225000)
        libxcb-dri2.so.0 => /usr/local/lib/libxcb-dri2.so.0 (0x81243a000)
        libxcb-xfixes.so.0 => /usr/local/lib/libxcb-xfixes.so.0 (0x81263e000)
        libxcb-shape.so.0 => /usr/local/lib/libxcb-shape.so.0 (0x812844000)
        libgbm.so.1 => /usr/local/lib/libgbm.so.1 (0x812a47000)
        libdrm.so.2 => /usr/local/lib/libdrm.so.2 (0x812c4d000)
        libXau.so.6 => /usr/local/lib/libXau.so.6 (0x812e5a000)
        libpthread-stubs.so.0 => /usr/local/lib/libpthread-stubs.so.0 (0x81305c000)
        libXdmcp.so.6 => /usr/local/lib/libXdmcp.so.6 (0x81325d000)
        libnvidia-tls.so.1 => /usr/local/lib/libnvidia-tls.so.1 (0x813462000)
        libnvidia-glcore.so.1 => /usr/local/lib/libnvidia-glcore.so.1 (0x813800000)
        libatspi.so.0 => /usr/local/lib/libatspi.so.0 (0x815a8c000)
Comment 2 Julien Cigar 2016-10-21 10:44:38 UTC
also, I have the java/icedtea-web port installed too (which trigger the libxul dependency), I suspect that it's because of this .. unfortunately but I don't have time to investigate now :(
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-10-21 10:45:20 UTC
CC Jan who committed [1] the last change (dropping versions from SONAME) in devel/nspr, which provides the apparent missing library, which may be implicated

http://svnweb.freebsd.org/changeset/ports/423591
Comment 4 Jochen Neumeister freebsd_committer 2016-10-21 10:51:08 UTC
See the Makefile:

TEST_BROKEN=		No rule to make target '../../../dist/bin/libnspr4.so', needed by \
			'../../../_tests/xpcshell/modules/libmar/tests/unit/libnspr4.so'
Comment 5 Jan Beich freebsd_committer 2016-10-21 11:03:44 UTC
Try doing "ldd -a ..." on a file that wants libplc4.so.1 to figure out which library also depends on nspr. I've bumped all explicit consumers, so firefox from pkg.freebsd.org repo works fine. If you mix packages from different repos it depends on pkg solver to work correctly, which is outside of gecko@ control.
Comment 6 Jan Beich freebsd_committer 2016-10-21 11:07:58 UTC
> Shared object "libplc4.so.1" not found, required by "libssl3.so"

Did you rebuild security/nss before devel/nspr? If both of them come from the same repo then it's a user issue likely resulting from manually upgrading packages.
Comment 7 Julien Cigar 2016-10-21 11:15:14 UTC
no, on the Poudriere box I did:
jcigar@duvel:~/ > sudo poudriere ports -uv

jcigar@duvel:~/ > sudo poudriere options -f /usr/local/etc/poudriere.d/pkglist/desktop -z desktop

jcigar@duvel:~/ > sudo poudriere bulk -f /usr/local/etc/poudriere.d/pkglist/desktop -j r10_1x64 -z desktop


then, on the client I did exactly this:
jcigar@frodon:~/ > sudo pkg update
Password:
Updating bebif repository catalogue...
bebif repository is up-to-date.
All repositories are up-to-date.

jcigar@frodon:~/ > sudo pkg install libreoffice
Updating bebif repository catalogue...
bebif repository is up-to-date.
All repositories are up-to-date.
The following 9 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        libreoffice: 5.0.6_4
        libe-book: 0.1.2_5

Installed packages to be UPGRADED:
        chromium: 52.0.2743.116_1 -> 52.0.2743.116_2
        libpurple: 2.11.0 -> 2.11.0_1
        firefox: 49.0_7,1 -> 49.0_8,1
        libxul: 45.4.0_5 -> 45.4.0_6
        nspr: 4.13 -> 4.13_1
        spidermonkey170: 17.0.0_1 -> 17.0.0_2
        nss: 3.27 -> 3.27.1_1

Number of packages to be installed: 2
Number of packages to be upgraded: 7

The process will require 303 MiB more space.
210 MiB to be downloaded.

Proceed with this action? [y/N]: y
Fetching libreoffice-5.0.6_4.txz: 100%   72 MiB  12.6MB/s    00:06    
Fetching chromium-52.0.2743.116_2.txz: 100%   42 MiB  10.9MB/s    00:04    
Fetching libpurple-2.11.0_1.txz: 100%    5 MiB   5.3MB/s    00:01    
Fetching firefox-49.0_8,1.txz: 100%   40 MiB  13.9MB/s    00:03    
Fetching libxul-45.4.0_6.txz: 100%   48 MiB  12.6MB/s    00:04    
Fetching nspr-4.13_1.txz: 100%  229 KiB 234.9kB/s    00:01    
Fetching spidermonkey170-17.0.0_2.txz: 100%    1 MiB   1.3MB/s    00:01    
Fetching nss-3.27.1_1.txz: 100%    2 MiB   1.8MB/s    00:01    
Fetching libe-book-0.1.2_5.txz: 100%  656 KiB 671.7kB/s    00:01    
Checking integrity... done (0 conflicting)
[1/9] Upgrading nspr from 4.13 to 4.13_1...
[1/9] Extracting nspr-4.13_1: 100%
[2/9] Upgrading spidermonkey170 from 17.0.0_1 to 17.0.0_2...
[2/9] Extracting spidermonkey170-17.0.0_2: 100%
[3/9] Upgrading nss from 3.27 to 3.27.1_1...
[3/9] Extracting nss-3.27.1_1: 100%
[4/9] Installing libe-book-0.1.2_5...
[4/9] Extracting libe-book-0.1.2_5: 100%
[5/9] Installing libreoffice-5.0.6_4...
[5/9] Extracting libreoffice-5.0.6_4: 100%
[6/9] Upgrading chromium from 52.0.2743.116_1 to 52.0.2743.116_2...
[6/9] Extracting chromium-52.0.2743.116_2: 100%
[7/9] Upgrading libpurple from 2.11.0 to 2.11.0_1...
[7/9] Extracting libpurple-2.11.0_1: 100%
[8/9] Upgrading firefox from 49.0_7,1 to 49.0_8,1...
[8/9] Extracting firefox-49.0_8,1: 100%
rmdir: /usr/local/lib/firefox: Directory not empty
[9/9] Upgrading libxul from 45.4.0_5 to 45.4.0_6...
[9/9] Extracting libxul-45.4.0_6: 100%
rmdir: /usr/local/lib/libxul/chrome: Directory not empty
rmdir: /usr/local/lib/libxul: Directory not empty
( messages hidden )
Comment 8 Jan Beich freebsd_committer 2016-10-21 11:53:22 UTC
It doesn't tell the story of how poudriere built nspr and nss packages. Try looking at nss build log. If it used nspr-4.13 rather than nspr-4.13_1 you have a problem. poudriere generally kills out of date dependencies even without PORTREVISION bumps.
Comment 9 Julien Cigar 2016-10-21 12:15:25 UTC
Here are the full logs, I first made a bulk which skipped some ports due to a problem in devel/llvm37: http://poudriere.bebif.be/build.html?mastername=r10_1x64-default-desktop&build=2016-10-19_17h02m51s apparently nspr-4.13_1 was used ..
After I found the issue in devel/llvm37 I launched another bulk: http://poudriere.bebif.be/build.html?mastername=r10_1x64-default-desktop&build=2016-10-19_22h15m59s

I'll try another build today to see if the problem could come from this
Comment 10 Julien Cigar 2016-10-21 13:32:19 UTC
I just tried to rebuild the packages but it doesn't resolve the issue:

jcigar@duvel:~/ > sudo poudriere bulk -j r10_1x64 -z desktop -C devel/nspr security/nss www/firefox www/libxul

(...)

[00:46:19] ====>> Stopping 8 builders
[00:48:17] ====>> Creating pkgng repository
Creating repository in /tmp/packages: 100%
Packing files for repository: 100%
[00:48:37] ====>> Committing packages to repository
[00:48:37] ====>> Removing old packages
[00:48:37] ====>> Built ports: devel/nspr lang/spidermonkey170 sysutils/polkit security/nss graphics/colord x11-toolkits/gtk30 www/libxul www/firefox
[r10_1x64-default-desktop] [2016-10-21_14h37m39s] [committing:] Queued: 8  Built: 8  Failed: 0  Skipped: 0  Ignored: 0  Tobuild: 0   Time: 00:48:25
[00:48:37] ====>> Logs: /usr/local/poudriere/data/logs/bulk/r10_1x64-default-desktop/2016-10-21_14h37m39s
[00:48:37] ====>> WWW: http://poudriere.bebif.be/logs//build.html?mastername=r10_1x64-default-desktop&build=2016-10-21_14h37m39s
[00:48:37] ====>> Cleaning up
[00:48:37] ====>> Umounting file systems

jcigar@frodon:~/ > sudo pkg update -f                         
Updating bebif repository catalogue...
Fetching meta.txz: 100%    824 B   0.8kB/s    00:01    
Fetching packagesite.txz: 100%  149 KiB 152.3kB/s    00:01    
Processing entries: 100%
bebif repository update completed. 624 packages processed.
jcigar@frodon:~/ > sudo pkg install -f firefox nss nspr libxul
Updating bebif repository catalogue...
bebif repository is up-to-date.
All repositories are up-to-date.
Checking integrity... done (0 conflicting)
The following 4 package(s) will be affected (of 0 checked):

Installed packages to be REINSTALLED:
        firefox-49.0_8,1
        nss-3.27.1_1
        nspr-4.13_1
        libxul-45.4.0_6

Number of packages to be reinstalled: 4

Proceed with this action? [y/N]: y
[1/4] Reinstalling nspr-4.13_1...
[1/4] Extracting nspr-4.13_1: 100%
[2/4] Reinstalling nss-3.27.1_1...
[2/4] Extracting nss-3.27.1_1: 100%
[3/4] Reinstalling firefox-49.0_8,1...
[3/4] Extracting firefox-49.0_8,1: 100%
rmdir: /usr/local/lib/firefox: Directory not empty
[4/4] Reinstalling libxul-45.4.0_6...
[4/4] Extracting libxul-45.4.0_6: 100%
rmdir: /usr/local/lib/libxul/chrome: Directory not empty
rmdir: /usr/local/lib/libxul: Directory not empty

jcigar@frodon:~/ > firefox 
XPCOMGlueLoad error for file /usr/local/lib/firefox/libxul.so:
Shared object "libplc4.so.1" not found, required by "libssl3.so"
Couldn't load XPCOM.
Comment 12 Julien Cigar 2016-10-21 13:37:57 UTC
another strange thing:

jcigar@frodon:~/ > find /usr/local/lib -name "*libssl3*"
/usr/local/lib/nss/libssl3.so
/usr/local/lib/firefox/libssl3.so

jcigar@frodon:~/ > ldd /usr/local/lib/nss/libssl3.so
/usr/local/lib/nss/libssl3.so:
        libnss3.so => /usr/local/lib/nss/libnss3.so (0x801656000)
        libnssutil3.so => /usr/local/lib/nss/libnssutil3.so (0x8019aa000)
        libplc4.so => /usr/local/lib/libplc4.so (0x801bd6000)
        libplds4.so => /usr/local/lib/libplds4.so (0x801dda000)
        libnspr4.so => /usr/local/lib/libnspr4.so (0x801fdd000)
        libz.so.6 => /lib/libz.so.6 (0x802219000)
        libthr.so.3 => /lib/libthr.so.3 (0x80242f000)
        libc.so.7 => /lib/libc.so.7 (0x800821000)

jcigar@frodon:~/ > ldd /usr/local/lib/firefox/libssl3.so
/usr/local/lib/firefox/libssl3.so:
        libnss3.so => /usr/local/lib/nss/libnss3.so (0x80163a000)
        libnssutil3.so => /usr/local/lib/nss/libnssutil3.so (0x80198e000)
        libplc4.so.1 => not found (0)
        libplds4.so.1 => not found (0)
        libnspr4.so.1 => not found (0)
        libthr.so.3 => /lib/libthr.so.3 (0x801bba000)
        libc.so.7 => /lib/libc.so.7 (0x800821000)
        libplc4.so => /usr/local/lib/libplc4.so (0x801dde000)
        libplds4.so => /usr/local/lib/libplds4.so (0x801fe2000)
        libnspr4.so => /usr/local/lib/libnspr4.so (0x8021e5000)
Comment 13 Jan Beich freebsd_committer 2016-10-21 15:37:19 UTC
> jcigar@frodon:~/ > ldd /usr/local/lib/firefox/libssl3.so
> /usr/local/lib/firefox/libssl3.so:
>         libnss3.so => /usr/local/lib/nss/libnss3.so (0x80163a000)
>         libnssutil3.so => /usr/local/lib/nss/libnssutil3.so (0x80198e000)

Try removing these files which are probably orphans from improperly removed package. To make sure check lib/firefox/dependentlibs.list doesn't mention libnss3.so.

Without those files libxul.so falls back to using system-wide copies. Bundled NSS is only built if you omit --with-system-nss e.g.,

  # make.conf or www/firefox/Makefile.local
  USE_MOZILLA+=	-nss

but looking at your Firefox log this is not the case.
Comment 14 Jan Beich freebsd_committer 2016-10-21 15:38:58 UTC
Err, remove the whole whole /usr/local/lib/firefox then reinstall firefox package.
Comment 15 Julien Cigar 2016-10-24 08:19:59 UTC
thanks, it works if I remove /usr/local/lib/firefox and then reinstall the package..! strange that I never had to do such thing before