Bug 213682 - www/py-formalchemy: Adjust SQLAlchemy dependency version (0.6 expired), UNBREAK for new upstream (GitHub)
Summary: www/py-formalchemy: Adjust SQLAlchemy dependency version (0.6 expired), UNBRE...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Rene Ladan
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks: 213680
  Show dependency treegraph
 
Reported: 2016-10-21 15:51 UTC by VK
Modified: 2016-12-08 20:13 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ghostonthewire)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description VK freebsd_triage 2016-10-21 15:51:25 UTC
databases/py-sqlalchemy06 expired, so the port needs to update sqlalchemy run time dependency version.

Also, as the port is currently BROKEN because the master site is GOOGLECODE, please unbreak with GitHub as upstream:

https://github.com/FormAlchemy/formalchemy
Comment 1 commit-hook freebsd_committer 2016-12-08 20:13:21 UTC
A commit references this bug:

Author: rene
Date: Thu Dec  8 20:12:52 UTC 2016
New revision: 428154
URL: https://svnweb.freebsd.org/changeset/ports/428154

Log:
  www/py-formalchemy: unexpire and update to 1.5.1
  - use GitHub mastersite
  - update sqlalchemy dependency to 1.0

  PR:		213682
  Submitted by:	vlad-fbsd@acheronmedia.com
  Approved by:	maintainer timeout (ghostonthewire@gmail.com)

Changes:
  head/www/py-formalchemy/Makefile
  head/www/py-formalchemy/distinfo
  head/www/py-formalchemy/pkg-descr