Bug 213693 - www/node: Copy to www/node6 (LTS version)
Summary: www/node: Copy to www/node6 (LTS version)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL: https://nodejs.org/en/blog/release/v6...
Keywords: patch-ready
Depends on: 213604 214386
Blocks: 213945 213947
  Show dependency treegraph
 
Reported: 2016-10-21 23:10 UTC by Eric Camachat
Modified: 2016-11-19 12:23 UTC (History)
4 users (show)

See Also:
bhughes: maintainer-feedback+


Attachments
clone www/node to www/node6 for new LTS (22.24 KB, patch)
2016-10-21 23:10 UTC, Eric Camachat
bhughes: maintainer-approval-
Details | Diff
node6-6.9.1 (15.67 KB, patch)
2016-10-31 12:35 UTC, Bradley T. Hughes
bhughes: maintainer-approval+
Details | Diff
www/node6, updated (15.67 KB, patch)
2016-11-01 21:06 UTC, Bradley T. Hughes
bhughes: maintainer-approval+
Details | Diff
www/node6: Copy from www/node (15.54 KB, patch)
2016-11-10 21:51 UTC, Bradley T. Hughes
bhughes: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Camachat 2016-10-21 23:10:00 UTC
Created attachment 176047 [details]
clone www/node to www/node6 for new LTS

From https://nodejs.org/en/blog/release/v6.9.0/
The v6 release line now moves in to "Active LTS".
Comment 1 Bradley T. Hughes freebsd_committer 2016-10-24 07:30:35 UTC
I see that the new port is at 6.9.1, but I'm still waiting for 213604 to be committed. Once that's done, I am all for this :)
Comment 2 Bradley T. Hughes freebsd_committer 2016-10-28 13:56:43 UTC
Comment on attachment 176047 [details]
clone www/node to www/node6 for new LTS

Patch needs updating now to pick up the changes I made to the www/node/Makefile in #213604.

Thanks much, this was my next TODO item, but now I can go straight to adding www/node7 :)
Comment 3 Bradley T. Hughes freebsd_committer 2016-10-31 12:35:49 UTC
Created attachment 176335 [details]
node6-6.9.1

I decided to add my own patch here, instead of creating a new, duplicated issue:
--
www/node6: Copy from www/node
    
Create a new port for the latest Node.js LTS release. Like www/node4,
this allows users/ports to depend on a specific major version.
    
The patch-node.gyp file has not been copied, as the problem this patch
addresses has been fixed upstream. Patches have been refreshed with
`make makepatch`.
Comment 4 Bradley T. Hughes freebsd_committer 2016-11-01 21:06:45 UTC
Created attachment 176399 [details]
www/node6, updated

portlint: OK (-AC, spurious warning about possible direct use of "python")
testport: OK (poudriere: 11.0-R, 10.[123]-R, 9.3-R, amd64/i386, default options)
testport: OK (poudriere: 11.0-R, 10.[123]-R, 9.3-R, amd64/i386, BUNDLED_SSL)
Comment 5 Bradley T. Hughes freebsd_committer 2016-11-10 21:51:19 UTC
Created attachment 176876 [details]
www/node6: Copy from www/node

Create a new port for the latest Node.js LTS release. Like www/node4,
this allows users/ports to depend on a specific major version.
    
The patch-node.gyp file has not been copied, as the problem this patch
addresses has been fixed upstream. Patches have been refreshed with
`make makepatch`.
    
Update CONFLICTS_INSTALL for all www/node* ports.
Comment 6 Bradley T. Hughes freebsd_committer 2016-11-10 21:51:58 UTC
Comment on attachment 176876 [details]
www/node6: Copy from www/node

portlint: OK (-AC, spurious warning about possible direct use of "python")
testport: OK (poudriere: 11.0-R, 10.[123]-R, 9.3-R, amd64/i386, default options)
testport: OK (poudriere: 11.0-R, 10.[123]-R, 9.3-R, amd64/i386, BUNDLED_SSL)
Comment 7 Kurt Jaeger freebsd_committer 2016-11-18 19:49:22 UTC
This behaves strange when it comes to download the distfile:

$ make fetch
===>  License MIT accepted by the user
===>   node6-6.9.1 depends on file: /usr/local/sbin/pkg - found
=> node-v6.9.1.tar.gz doesn't seem to exist in /home/pi/m/distfiles/.
=> Attempting to fetch http://nodejs.org/dist/v6.9.1/node-v6.9.1.tar.gz
fetch: 26504341: No such file or directory
node-v6.9.1.tar.gz                            100% of   25 MB  594 kBps 00m43s
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/node-v6.9.1.tar.gz
fetch: 26504341: No such file or directory
=> Couldn't fetch it - please try to retrieve this

Any idea why that happens ?
Comment 8 Kurt Jaeger freebsd_committer 2016-11-18 19:53:14 UTC
MASTER_SITE has some additional size field which somehow gets
mangled into the filename. That seems to be the cause:

node-v6.9.1.tar.gz                   19-Oct-2016 22:02            26504341
Comment 9 Adam Weinberger freebsd_committer 2016-11-18 20:05:22 UTC
Bradley, maybe the node ports should be fetching sources from Github?
Comment 10 Bradley T. Hughes freebsd_committer 2016-11-18 20:39:51 UTC
I cannot reproduce this:

$ make distclean
===>  Cleaning for node6-6.9.1
===>  Deleting distfiles for node6-6.9.1
$ make fetch
===>  License MIT accepted by the user
===>   node6-6.9.1 depends on file: /usr/local/sbin/pkg - found
=> node-v6.9.1.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://nodejs.org/dist/v6.9.1/node-v6.9.1.tar.gz
node-v6.9.1.tar.gz                            100% of   25 MB   14 MBps 00m01s
===> Fetching all distfiles required by node6-6.9.1 for building
$
Comment 11 Bradley T. Hughes freebsd_committer 2016-11-18 21:06:07 UTC
(In reply to Adam Weinberger from comment #9)

Adam: I have considered it.
Comment 12 Kurt Jaeger freebsd_committer 2016-11-19 08:31:01 UTC
The distinfo file was twice the same lines. This seems to be the cause.

------------
TIMESTAMP = 1476953621
SHA256 (node-v6.9.1.tar.gz) = a98997ca3a4d10751f0ebe97839b2308a31ae884b4203cda0c99cf36bc7fe3bf
SIZE (node-v6.9.1.tar.gz) = 26504341
TIMESTAMP = 1476953621
SHA256 (node-v6.9.1.tar.gz) = a98997ca3a4d10751f0ebe97839b2308a31ae884b4203cda0c99cf36bc7fe3bf
SIZE (node-v6.9.1.tar.gz) = 26504341
------------
Comment 13 Kurt Jaeger freebsd_committer 2016-11-19 08:33:29 UTC
testbuilds@work
Comment 14 Kurt Jaeger freebsd_committer 2016-11-19 09:34:19 UTC
Well, pkg-plist, pkg-message and pkg-descr were duplicated, too.
Comment 15 Bradley T. Hughes freebsd_committer 2016-11-19 11:25:03 UTC
Duplicated how? The patch I added doesn't show any duplicated lines.
Comment 16 Kurt Jaeger freebsd_committer 2016-11-19 12:16:47 UTC
Like distinfo: same contents added to the file after the first instance.
Really strange.
Comment 17 commit-hook freebsd_committer 2016-11-19 12:21:50 UTC
A commit references this bug:

Author: pi
Date: Sat Nov 19 12:21:23 UTC 2016
New revision: 426362
URL: https://svnweb.freebsd.org/changeset/ports/426362

Log:
  www/node: Copy to www/node6 as LTS version

  PR:		213693
  Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)

Changes:
  head/www/Makefile
  head/www/node/Makefile
  head/www/node012/Makefile
  head/www/node4/Makefile
  head/www/node6/
  head/www/node6/Makefile
  head/www/node6/files/patch-deps_v8_src_arm_cpu-arm.cc
  head/www/node6/files/patch-deps_v8_src_base_atomicops__internals__arm__gcc.h
  head/www/node6/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
  head/www/node6/files/patch-deps_v8_src_log-utils.h
  head/www/node6/files/patch-deps_v8_src_profiler_sampler.cc
Comment 18 Kurt Jaeger freebsd_committer 2016-11-19 12:22:53 UTC
Committed, thanks!
Comment 19 Bradley T. Hughes freebsd_committer 2016-11-19 12:23:02 UTC
Thanks Kurt :)