Bug 213728 - www/httpie: Rename to py-httpie (support multiple/concurrent versions)
Summary: www/httpie: Rename to py-httpie (support multiple/concurrent versions)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason Unovitch
URL:
Keywords:
: 212795 (view as bug list)
Depends on:
Blocks: 213700
  Show dependency treegraph
 
Reported: 2016-10-23 12:47 UTC by Danilo G. Baio
Modified: 2017-01-09 02:57 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (ale)


Attachments
httpie-rename.patch (1.79 KB, patch)
2016-10-23 12:47 UTC, Danilo G. Baio
dbaio: maintainer-approval? (ale)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Danilo G. Baio freebsd_committer 2016-10-23 12:47:53 UTC
Created attachment 176082 [details]
httpie-rename.patch

- Rename to py-httpie (support multiple/concurrent versions) [1]
- Fix dependencies
- Set architecture neutral
- Bump PORTREVISION

That's how I've tried:

$ svn patch /tmp/httpie-rename.patch
U         MOVED
U         www/Makefile
U         www/httpie/Makefile

$ svn move www/httpie/ www/py-httpie/
A         www/py-httpie
D         www/httpie
D         www/httpie/Makefile
D         www/httpie/distinfo
D         www/httpie/pkg-descr

Fix permissions [2]:
chmod 644 MOVED www/Makefile www/py-httpie/Makefile

$ svn status
M       MOVED
M       www/Makefile
D       www/httpie
        > moved to ../py-httpie
D       www/httpie/Makefile
D       www/httpie/distinfo
D       www/httpie/pkg-descr
A  +    www/py-httpie
        > moved from ../httpie
M  +    www/py-httpie/Makefile


[1] - Reported by koobs@ on IRC, support multiple/concurrent 
      versions on httpie and py-http-prompt)

[2] - https://issues.apache.org/jira/browse/SVN-4651


[Q/A]

portlint: OK (looks fine.)
testport: python 2.7 and 3.4
	poudriere: i386,  9.3   (OK)
	poudriere: amd64, 9.3   (OK)
	poudriere: i386,  10.3  (OK)
	poudriere: amd64, 10.3  (OK)
	poudriere: i386,  11    (OK)
	poudriere: amd64, 11    (OK)
	poudriere: i386,  12    (OK)
	poudriere: amd64, 12    (OK)
Comment 1 Danilo G. Baio freebsd_committer 2016-10-23 12:52:23 UTC
*** Bug 212795 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2017-01-09 02:53:24 UTC
A commit references this bug:

Author: junovitch
Date: Mon Jan  9 02:53:06 UTC 2017
New revision: 430906
URL: https://svnweb.freebsd.org/changeset/ports/430906

Log:
  devel/py-http-prompt: update 0.6.0 -> 0.8.0; update dependency [1]

  - Update dependency version
  - Rename dependency to match standard Python package naming and support
    multiple/concurrent versions on httpie and py-http-prompt

  www/py-httpie: rename from www/httpie; fix dependencies; set NO_ARCH [2]
  www/Makefile: chase rename
  MOVED: document rename

  Changelog:
  - 0.7.0
  * New feature: Shell substitution (#54, #61, #74)
  * New feature: Piping to shell (#61, #74)
  * New feature: Be able to delete all parameters of a given type (#
  - 0.8.0
  * Add support for OPTIONS method (#84)
  * Fix highlighting bug with parameters starting with HTTP method names (#86)
  * Fix excessive newlines after headers and body (#89)

  PR:		213700 [1]
  PR:		213728 [2]
  Submitted by:	Danilo G. Baio <dbaio@bsd.com.br> (maintainer)

Changes:
  head/MOVED
  head/devel/py-http-prompt/Makefile
  head/devel/py-http-prompt/distinfo
  head/www/Makefile
  head/www/httpie/
  head/www/py-httpie/
  head/www/py-httpie/Makefile
Comment 3 Jason Unovitch freebsd_committer 2017-01-09 02:57:05 UTC
Take for PR close. Applied as a "just fix it" to get this port in line with Python package naming in pursuit of bug #213700.