Bug 213745 - sysutils/debootstrap: Update to 1.0.85
Summary: sysutils/debootstrap: Update to 1.0.85
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-24 15:18 UTC by Nikolai Lifanov
Modified: 2016-10-25 19:51 UTC (History)
1 user (show)

See Also:


Attachments
sysutils/debootstrap 1.0.84 -> 1.0.85 (1.74 KB, patch)
2016-10-24 15:18 UTC, Nikolai Lifanov
lifanov: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolai Lifanov 2016-10-24 15:18:03 UTC
Created attachment 176103 [details]
sysutils/debootstrap 1.0.84 -> 1.0.85

Please update sysutils/debootstrap to 1.0.85

debootstrap (1.0.85) unstable; urgency=medium

  [ Julien Cristau ]
  * Add support for downloading and validating InRelease files, by splitting
    up detached signature from signed data.
  * Switch default mirror to deb.debian.org.

  [ Colin Watson ]
  * Add (Ubuntu) zesty as a symlink to gutsy.

  [ Ansgar Burchardt ]
  * Add jessie-kfreebsd to merged-/usr blacklist.
  * No longer Build-Depend on makedev. The code using it was already
    removed in debootstrap 1.0.82.
  * Do not use `tar -k` for older releases which might have file
    conflicts between the packages to be installed. (Closes: #838388)
  * Error out when seeing short options. (Closes: #548880)
  * Add oldoldstable -> sid script symlink. (Closes: #792734)
  * Add buster -> sid and bullseye -> sid script symlinks.
  * Only unpack and configure the base system when there are actually
    packages to install. (Closes: #825034)
  * debootstrap.8: Use stretch instead of wheezy in examples.

  [ Marco d'Itri ]
  * Enable merged-/usr by default. (Closes: #839046)

 -- Julien Cristau <jcristau@debian.org>  Fri, 21 Oct 2016 20:22:49 +0200
Comment 1 Kurt Jaeger freebsd_committer 2016-10-25 19:50:54 UTC
Committed, thanks!
Comment 2 commit-hook freebsd_committer 2016-10-25 19:51:45 UTC
A commit references this bug:

Author: pi
Date: Tue Oct 25 19:50:45 UTC 2016
New revision: 424648
URL: https://svnweb.freebsd.org/changeset/ports/424648

Log:
  sysutils/debootstrap: update 1.0.84 -> 1.0.85

  - Add support for downloading and validating InRelease files, by splitting
    up detached signature from signed data.
  - Switch default mirror to deb.debian.org.
  - Add (Ubuntu) zesty as a symlink to gutsy.
  - Add jessie-kfreebsd to merged-/usr blacklist.
  - No longer Build-Depend on makedev. The code using it was already
    removed in debootstrap 1.0.82.
  - Do not use `tar -k` for older releases which might have file
    conflicts between the packages to be installed. (Closes: #838388)
  - Error out when seeing short options. (Closes: #548880)
  - Add oldoldstable -> sid script symlink. (Closes: #792734)
  - Add buster -> sid and bullseye -> sid script symlinks.
  - Only unpack and configure the base system when there are actually
    packages to install. (Closes: #825034)
  - debootstrap.8: Use stretch instead of wheezy in examples.
  - Enable merged-/usr by default. (Closes: #839046)

  PR:		213745
  Submitted by:	Nikolai Lifanov <lifanov@mail.lifanov.com> (maintainer)

Changes:
  head/sysutils/debootstrap/Makefile
  head/sysutils/debootstrap/distinfo
  head/sysutils/debootstrap/pkg-plist