Bug 213765 - archivers/libarchive: Fails to compile
Summary: archivers/libarchive: Fails to compile
Status: Closed DUPLICATE of bug 210626
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-25 08:20 UTC by Walter Schwarzenfeld
Modified: 2016-10-25 09:44 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2016-10-25 08:20:52 UTC
Update to 3.2.2 fails with
make[3]: stopped in /ram/usr/ports/archivers/libarchive/work/libarchive-3.2.2
--- bsdcpio ---
./.libs/libarchive.a(archive_read_support_filter_lzop.o): In function `lzop_filter_read':
libarchive/archive_read_support_filter_lzop.c:(.text+0x6a5): undefined reference to `lzo1x_decompress_safe'
./.libs/libarchive.a(archive_read_support_format_xar.o): In function `xar_read_header':
libarchive/archive_read_support_format_xar.c:(.text+0x5cd): undefined reference to `XML_ParserCreate'
libarchive/archive_read_support_format_xar.c:(.text+0x5e8): undefined reference to `XML_SetUserData'
libarchive/archive_read_support_format_xar.c:(.text+0x5fa): undefined reference to `XML_SetElementHandler'
libarchive/archive_read_support_format_xar.c:(.text+0x60e): undefined reference to `XML_SetCharacterDataHandler'
libarchive/archive_read_support_format_xar.c:(.text+0x6a4): undefined reference to `XML_Parse'
libarchive/archive_read_support_format_xar.c:(.text+0x6ce): undefined reference to `XML_ParserFree'
libarchive/archive_read_support_format_xar.c:(.text+0x6e6): undefined reference to `XML_ParserFree'
./.libs/libarchive.a(archive_write_add_filter_lzop.o): In function `archive_write_add_filter_lzop':
libarchive/archive_write_add_filter_lzop.c:(.text+0xd6): undefined reference to `__lzo_init_v2'
libarchive/archive_write_add_filter_lzop.c:(.text+0x117): undefined reference to `lzo_version'
libarchive/archive_write_add_filter_lzop.c:(.text+0x12b): undefined reference to `lzo_version_string'
./.libs/libarchive.a(archive_write_add_filter_lzop.o): In function `drive_compressor':
libarchive/archive_write_add_filter_lzop.c:(.text+0x44f): undefined reference to `lzo_version'
libarchive/archive_write_add_filter_lzop.c:(.text+0x45c): undefined reference to `lzo_version'
libarchive/archive_write_add_filter_lzop.c:(.text+0x4e4): undefined reference to `lzo_adler32'
libarchive/archive_write_add_filter_lzop.c:(.text+0x54f): undefined reference to `lzo1x_1_15_compress'
libarchive/archive_write_add_filter_lzop.c:(.text+0x598): undefined reference to `lzo1x_999_compress_level'
libarchive/archive_write_add_filter_lzop.c:(.text+0x5be): undefined reference to `lzo1x_1_compress'
--- bsdtar ---
./.libs/libarchive.a(archive_read_support_filter_lzop.o): In function `lzop_filter_read':
--- bsdcpio ---
libarchive/archive_write_add_filter_lzop.c:(.text+0x62b): undefined reference to `lzo_adler32'
--- bsdtar ---
libarchive/archive_read_support_filter_lzop.c:(.text+0x6a5): undefined reference to `lzo1x_decompress_safe'
./.libs/libarchive.a(archive_read_support_format_xar.o): In function `xar_read_header':
libarchive/archive_read_support_format_xar.c:(.text+0x5cd): undefined reference to `XML_ParserCreate'
libarchive/archive_read_support_format_xar.c:(.text+0x5e8): undefined reference to `XML_SetUserData'
libarchive/archive_read_support_format_xar.c:(.text+0x5fa): undefined reference to `XML_SetElementHandler'
libarchive/archive_read_support_format_xar.c:(.text+0x60e): undefined reference to `XML_SetCharacterDataHandler'
libarchive/archive_read_support_format_xar.c:(.text+0x6a4): undefined reference to `XML_Parse'
libarchive/archive_read_support_format_xar.c:(.text+0x6ce): undefined reference to `XML_ParserFree'
libarchive/archive_read_support_format_xar.c:(.text+0x6e6): undefined reference to `XML_ParserFree'
./.libs/libarchive.a(archive_write_add_filter_lzop.o): In function `archive_write_add_filter_lzop':
libarchive/archive_write_add_filter_lzop.c:(.text+0xd6): undefined reference to `__lzo_init_v2'
libarchive/archive_write_add_filter_lzop.c:(.text+0x117): undefined reference to `lzo_version'
libarchive/archive_write_add_filter_lzop.c:(.text+0x12b): undefined reference to `lzo_version_string'
./.libs/libarchive.a(archive_write_add_filter_lzop.o): In function `drive_compressor':
libarchive/archive_write_add_filter_lzop.c:(.text+0x44f): undefined reference to `lzo_version'
libarchive/archive_write_add_filter_lzop.c:(.text+0x45c): undefined reference to `lzo_version'
libarchive/archive_write_add_filter_lzop.c:(.text+0x4e4): undefined reference to `lzo_adler32'
libarchive/archive_write_add_filter_lzop.c:(.text+0x54f): undefined reference to `lzo1x_1_15_compress'
libarchive/archive_write_add_filter_lzop.c:(.text+0x598): undefined reference to `lzo1x_999_compress_level'
libarchive/archive_write_add_filter_lzop.c:(.text+0x5be): undefined reference to `lzo1x_1_compress'
libarchive/archive_write_add_filter_lzop.c:(.text+0x62b): undefined reference to `lzo_adler32'
--- bsdcpio ---
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** [bsdcpio] Error code 1

make[3]: stopped in /ram/usr/ports/archivers/libarchive/work/libarchive-3.2.2
--- bsdtar ---
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** [bsdtar] Error code 1

make[3]: stopped in /ram/usr/ports/archivers/libarchive/work/libarchive-3.2.2
3 errors

make[3]: stopped in /ram/usr/ports/archivers/libarchive/work/libarchive-3.2.2
*** [all] Error code 2

make[2]: stopped in /ram/usr/ports/archivers/libarchive/work/libarchive-3.2.2
1 error

make[2]: stopped in /ram/usr/ports/archivers/libarchive/work/libarchive-3.2.2
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/archivers/libarchive
*** Error code 1

Stop.
make: stopped in /usr/ports/archivers/libarchive


Now I am a little bit angry. Every update the problem with liblzma.so....
Comment 1 Walter Schwarzenfeld freebsd_triage 2016-10-25 08:33:24 UTC
The solution is the same i wrote in PR 210626.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-10-25 08:47:06 UTC
(In reply to w.schwarzenfeld from comment #1)

Is this a different cause or error than those documented in bug 210626? If not, please clarify the purpose for a separate/new issue.

Also, for future issues please use attachments (not comments) for large text outputs such as build or error logs, configuration files, etc.

While I'm here, correct typo in Summary and assign to maintainer accordingly.
Comment 3 Walter Schwarzenfeld freebsd_triage 2016-10-25 09:01:12 UTC
It is the same problem, only the versions of libarchive are different. The CFLAGS and LDFLAGS are wrong, if liblzma is installed. My solution is to cmment it out and add liblzma.so:archivers/lzmalib to LIB_DEPENDS. This works on 10.X and 11.0 but not on 9.3.
Comment 4 Walter Schwarzenfeld freebsd_triage 2016-10-25 09:05:31 UTC
Correct: ..if archivers/lzmalib is installed.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-10-25 09:44:16 UTC
The root cause of the problem should be resolved in the original issue as reported.

*** This bug has been marked as a duplicate of bug 210626 ***