Bug 213822 - www/obhttpd: unblock package build via static libressl
Summary: www/obhttpd: unblock package build via static libressl
Status: Closed DUPLICATE of bug 219081
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2016-10-27 00:04 UTC by Jan Beich
Modified: 2018-01-10 09:43 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (koue)
jbeich: merge-quarterly?


Attachments
v1 (1.30 KB, patch)
2016-10-27 00:04 UTC, Jan Beich
no flags Details | Diff
9.3R i386 |poudriere bulk -t| log (XZ compressed) (58.67 KB, application/x-xz)
2016-10-27 00:04 UTC, Jan Beich
no flags Details
svn diff for www/obhttpd v1.1 (1.27 KB, patch)
2016-10-30 15:28 UTC, Bernard Spil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2016-10-27 00:04:17 UTC
Created attachment 176205 [details]
v1

+++ This bug was initially created as a clone of Bug #213691 +++

LibreSSL is currently ABI-incompatible with OpenSSL. One way to bypass ABI is to not rely on it by using a static library. This is an example how to bundle such a library.
Comment 1 Jan Beich freebsd_committer 2016-10-27 00:04:51 UTC
Created attachment 176206 [details]
9.3R i386 |poudriere bulk -t| log (XZ compressed)
Comment 2 Bernard Spil freebsd_committer 2016-10-30 15:28:38 UTC
Created attachment 176311 [details]
svn diff for www/obhttpd v1.1

Updated patch v1 to work if user has DEFAULT_VERSIONS= ssl=openssl defined

See bug #213691 describing the issue with setting USES= ssl generating conflicts errors.
Comment 3 Jan Beich freebsd_committer 2016-10-30 15:58:45 UTC
Comment on attachment 176311 [details]
svn diff for www/obhttpd v1.1

USES=ssl has no effect after bsd.port.pre.mk. CONFLICTS issue is due to bug 213889 and bug 213890. ports 424949 broke build for DEFAULT_VERSIONS=ssl=libressl in poudriere:

  =======================<phase: build          >============================
  ===>  Building for acme-client-0.1.11_2
  [...]
  cc -O2 -pipe  -fstack-protector -fno-strict-aliasing -g -W -Wall -DHAVE_CONFIG_H -I/usr/local/include   -c -o http.o http.c
  http.c:34:10: fatal error: 'tls.h' file not found
  #include <tls.h>
	   ^
  1 error generated.

So, I cannot approve your v1.
Comment 4 Thomas Zander freebsd_committer 2016-12-04 17:05:04 UTC
Hmm ... if it doesn't build, it's not patch-ready and needs a new one :-)
Comment 5 Jan Beich freebsd_committer 2016-12-04 18:59:54 UTC
Comment on attachment 176311 [details]
svn diff for www/obhttpd v1.1

Feedback timeout.
Comment 6 Jan Beich freebsd_committer 2016-12-04 19:03:12 UTC
Comment on attachment 176205 [details]
v1

While this one should work naddy's version in net/openntpd maybe slightly better.
Comment 7 Martin Wilke freebsd_committer 2017-03-05 11:03:02 UTC
Hi Jan,

Can we close this pr ?
Comment 8 Bernard Spil freebsd_committer 2017-03-06 06:38:37 UTC
Think the question is if Jan is willing to integrate the patch.

I merged a similar change for acme-client that works OK.
Comment 10 Walter Schwarzenfeld freebsd_triage 2018-01-10 02:14:01 UTC
ping!
Comment 11 Nikola Kolev 2018-01-10 09:34:42 UTC
pong!
Comment 12 Jan Beich freebsd_committer 2018-01-10 09:43:15 UTC
A bit different fix landed in ports r453878.

*** This bug has been marked as a duplicate of bug 219081 ***