Bug 213825 - audio/pulseaudio-module-sndio: Fix build after PulseAudio 9.0 update
Summary: audio/pulseaudio-module-sndio: Fix build after PulseAudio 9.0 update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords: easy, patch, regression
Depends on:
Blocks: 210548
  Show dependency treegraph
 
Reported: 2016-10-27 04:42 UTC by Tobias Kortkamp
Modified: 2016-10-27 10:22 UTC (History)
2 users (show)

See Also:


Attachments
pulseaudio-module-sndio.diff (1.27 KB, patch)
2016-10-27 04:42 UTC, Tobias Kortkamp
tobik: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2016-10-27 04:42:56 UTC
Created attachment 176209 [details]
pulseaudio-module-sndio.diff

portlint ok, poudriere build on FreeBSD 10.3/amd64 ok
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-10-27 08:54:32 UTC
If this ports version should always match the pulseaudio version (for api, or other reasons), at least comments should be added to the appropriate port(s) so that updates such as these are not forgotten.

Better than a comment would be some™ mechanism that fails safe/closed rather than open (and broken) as is the case for this issue.

CC'ing participants (reporter and committer) of bug 210548 (the pulseaudio update issue)
Comment 2 commit-hook freebsd_committer 2016-10-27 10:16:20 UTC
A commit references this bug:

Author: jbeich
Date: Thu Oct 27 10:16:09 UTC 2016
New revision: 424755
URL: https://svnweb.freebsd.org/changeset/ports/424755

Log:
  audio/pulseaudio-module-sndio: update to 9.0 to unbreak after r424621

  cc -shared module-sndio.o  -Wl,-rpath -Wl,/usr/local/lib  -Wl,-rpath -Wl,/usr/local/lib/pulseaudio   -fstack-protector  -L/usr/local/lib  -L/usr/local/lib/pulseaudio  -lpulsecore-8.0  -lpulsecommon-8.0  -lpulse  -lsndio  -o module-sndio.so
  /usr/bin/ld: cannot find -lpulsecore-8.0
  cc: error: linker command failed with exit code 1 (use -v to see invocation)
  *** Error code 1

  Changes:	https://github.com/t6/pulseaudio-module-sndio/compare/8.0...9.0
  PR:		213825
  Reported by:	pkg-fallout
  Submitted by:	Tobias Kortkamp (maintainer)

Changes:
  head/audio/pulseaudio-module-sndio/Makefile
  head/audio/pulseaudio-module-sndio/distinfo
Comment 3 Jan Beich freebsd_committer 2016-10-27 10:17:59 UTC
Thanks. Landed. koobs@, bustages due to hardcoded versions are rare, see
https://github.com/t6/pulseaudio-module-sndio/commit/ad32779


FWIW, MAKE_ARGS from the port's Makefile can be dropped if you rename STAGEDIR to (more common) DESTDIR upstream.

https://www.gnu.org/software/automake/manual/html_node/DESTDIR.html
https://cmake.org/cmake/help/v3.0/variable/CMAKE_INSTALL_PREFIX.html