Bug 213908 - x11/nvidia-driver: 367.44 causes Xorg misbehavior: mouse stops working
Summary: x11/nvidia-driver: 367.44 causes Xorg misbehavior: mouse stops working
Status: Closed Not Accepted
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-30 06:15 UTC by Yuri Victorovich
Modified: 2016-10-30 09:08 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2016-10-30 06:15:05 UTC
Hi,

After I upgraded from 346.96 to 367.44 (with replacement of nvidia.ko -> nvidia-modeset.ko), Xorg began to misbehave. In kde4 after a while mouse clicks stop working, though the cursor itself moves. When I unplug the USB mouse and plug it back it works for a while and then stops working again. This happened on 10.3 after the nvidia-driver upgrade. I upgraded OS to 11.0 with full package reinstall, and the problem persisted. Then I downgraded nvidia-driver back to 346.96 and the problem is gone. So nvidia-driver is clearly the cause. This problem makes the system unusable.

I don't understand why nvidia driver would affect the mouse, but that is what I am observing.

GT610.
Comment 1 Yuri Victorovich freebsd_committer 2016-10-30 09:06:51 UTC
Sorry, I probably got confused. It wasn't nvidia-driver that caused the problem.