Bug 213923 - Adjust text/plain autodetection for attachments
Summary: Adjust text/plain autodetection for attachments
Status: Closed FIXED
Alias: None
Product: Services
Classification: Unclassified
Component: Bug Tracker (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Many People
Assignee: Bugmeister
URL:
Keywords:
: 194990 205333 (view as bug list)
Depends on:
Blocks: 205623
  Show dependency treegraph
 
Reported: 2016-10-30 21:19 UTC by Jan Beich
Modified: 2018-03-04 18:20 UTC (History)
2 users (show)

See Also:


Attachments
shar archive (676.03 KB, text/plain)
2018-02-11 21:51 UTC, Oleksandr Tymoshenko
no flags Details
svn.diff (977 bytes, patch)
2018-02-11 21:55 UTC, Oleksandr Tymoshenko
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2016-10-30 21:19:10 UTC
As a ports/ peer I occasionally browse many patches trying to find those having the least amount of issues. If an attachment cannot be viewed within a browser this often means closing tab and moving on to the next. To avoid neglecting such bugs adjusting "Content type: auto-detect" may help:

- application/shar -> text/plain
- application/x-shar -> text/plain
- text/x-patch or text/x-diff -> text/plain + mark as "patch"
- text/* -> text/plain
Comment 1 Jan Beich freebsd_committer 2016-10-30 21:50:12 UTC
Having a bot periodically (e.g. once a hour) convert types would work as well.
Comment 2 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-02-11 21:47:13 UTC
*** Bug 205333 has been marked as a duplicate of this bug. ***
Comment 3 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-02-11 21:51:34 UTC
Created attachment 190524 [details]
shar archive
Comment 4 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-02-11 21:55:24 UTC
Created attachment 190525 [details]
svn.diff
Comment 5 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-02-11 21:56:09 UTC
Fix was implemented as a hook in Bugzilla extensions:
https://github.com/gonzoua/bugzilla/commit/4b462b2bc53bb25b856b675aa24705f0912439fc
Comment 6 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-02-11 22:39:44 UTC
*** Bug 194990 has been marked as a duplicate of this bug. ***