Bug 213971 - devel/git as 198768: install fail for git-2.10.1
Summary: devel/git as 198768: install fail for git-2.10.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Renato Botelho
URL:
Keywords:
: 214986 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-01 10:33 UTC by Dmitry Ivanov
Modified: 2016-12-08 20:30 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (garga)


Attachments
config.log (100.61 KB, text/plain)
2016-12-02 17:13 UTC, Dmitry Ivanov
no flags Details
build.output (6.50 KB, text/plain)
2016-12-03 10:37 UTC, Dmitry Ivanov
no flags Details
output (20.71 KB, application/x-gzip)
2016-12-08 19:03 UTC, Dmitry Ivanov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Ivanov 2016-11-01 10:33:13 UTC
--->  Installing the new version via the port
===>  Installing for git-2.10.1_1
===>   git-2.10.1_1 depends on executable: curl - found
===>   git-2.10.1_1 depends on executable: cvsps - found
===>   git-2.10.1_1 depends on package: p5-Error>=0 - found
===>   git-2.10.1_1 depends on package: p5-Net-SMTP-SSL>=0 - found
===>   git-2.10.1_1 depends on package: p5-Authen-SASL>=0 - found
===>   git-2.10.1_1 depends on package: p5-Term-ReadKey>=0 - found
===>   git-2.10.1_1 depends on package: p5-subversion>=0 - found
===>   git-2.10.1_1 depends on file: /usr/local/lib/libcrypto.so.9 - found
===>   git-2.10.1_1 depends on file: /usr/local/bin/python2.7 - found
===>   git-2.10.1_1 depends on package: perl5>=5.20<5.21 - found
===>   git-2.10.1_1 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so)
===>   git-2.10.1_1 depends on shared library: libpcre.so - found (/usr/local/lib/libpcre.so)
===>   git-2.10.1_1 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   Registering installation for git-2.10.1_1
pkg-static: Unable to access file /usr/ports/devel/git/work/stage/usr/local/libexec/git-core/git-http-fetch: No such file or directory
pkg-static: Unable to access file /usr/ports/devel/git/work/stage/usr/local/libexec/git-core/git-http-push: No such file or directory
pkg-static: Unable to access file /usr/ports/devel/git/work/stage/usr/local/libexec/git-core/git-remote-ftp: No such file or directory
pkg-static: Unable to access file /usr/ports/devel/git/work/stage/usr/local/libexec/git-core/git-remote-ftps: No such file or directory
pkg-static: Unable to access file /usr/ports/devel/git/work/stage/usr/local/libexec/git-core/git-remote-http: No such file or directory
pkg-static: Unable to access file /usr/ports/devel/git/work/stage/usr/local/libexec/git-core/git-remote-https: No such file or directory
*** Error code 74

Stop.
make[2]: stopped in /usr/ports/devel/git
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/git
*** Error code 1

Stop.
Comment 1 Renato Botelho freebsd_committer 2016-12-01 15:04:47 UTC
Can you please test current version (2.11.0) and check if bug persists?
Comment 2 Renato Botelho freebsd_committer 2016-12-01 16:02:02 UTC
Fixed by commit https://svnweb.freebsd.org/changeset/ports/427505
Comment 3 Dmitry Ivanov 2016-12-01 17:07:02 UTC
(In reply to Renato Botelho from comment #1)
This version has no problems. The bug can be closed, thanks.
Comment 4 Renato Botelho freebsd_committer 2016-12-01 19:13:58 UTC
Reopen, the cause of those files not being built were a curl error

/usr/local/lib/libcurl.so: undefined reference to `basename@FBSD_1.5'

I'm checking what happened and will fix it ASAP
Comment 5 Renato Botelho freebsd_committer 2016-12-01 19:14:44 UTC
*** Bug 214986 has been marked as a duplicate of this bug. ***
Comment 6 commit-hook freebsd_committer 2016-12-01 19:23:22 UTC
A commit references this bug:

Author: garga
Date: Thu Dec  1 19:23:08 UTC 2016
New revision: 427513
URL: https://svnweb.freebsd.org/changeset/ports/427513

Log:
  Revert part of r427504

  Helpers used to access http(s) and ftp(s) were not being built due to an error
  on libcurl, then they ended up showing as PLIST errors.

  PR:		213971

Changes:
  head/devel/git/Makefile
  head/devel/git/pkg-plist
Comment 7 Renato Botelho freebsd_committer 2016-12-01 19:26:27 UTC
(In reply to Dmitry Ivanov from comment #3)

Can you send me a uname -a of the system you are facing this issue? I suspect you are running HEAD from sometime before Nov 3, is it correct?
Comment 8 Dmitry Ivanov 2016-12-01 20:25:18 UTC
(In reply to Renato Botelho from comment #7)
$ uname -a
FreeBSD gate2 10.2-RELEASE FreeBSD 10.2-RELEASE #0 r286666: Wed Aug 12 15:26:37 UTC 2015     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
Comment 9 Jens Grassel 2016-12-02 06:42:08 UTC
Using port version git-2.11.0_2 compiled on 11.0 it works.

Many thanks for fixing this.
Comment 10 Renato Botelho freebsd_committer 2016-12-02 10:30:03 UTC
(In reply to Dmitry Ivanov from comment #8)

Please run "make configure" and send me ./work/git-2.11.0/config.log
Comment 11 Dmitry Ivanov 2016-12-02 17:13:12 UTC
Created attachment 177611 [details]
config.log
Comment 12 Dmitry Ivanov 2016-12-02 17:14:07 UTC
in the attachment
Comment 13 Renato Botelho freebsd_committer 2016-12-02 18:47:08 UTC
(In reply to Dmitry Ivanov from comment #12)
One more item I forgot to ask before, build output
Comment 14 Dmitry Ivanov 2016-12-03 10:37:25 UTC
Created attachment 177630 [details]
build.output

This?
Comment 15 Renato Botelho freebsd_committer 2016-12-08 17:13:33 UTC
(In reply to Dmitry Ivanov from comment #14)
# cd /usr/ports/devel/git
# make >/tmp/output 2>&1
Comment 16 Renato Botelho freebsd_committer 2016-12-08 17:14:31 UTC
And just confirming, you are using an up2date ports tree with last git version?
Comment 17 Dmitry Ivanov 2016-12-08 19:03:52 UTC
Created attachment 177809 [details]
output
Comment 18 Dmitry Ivanov 2016-12-08 19:05:09 UTC
(In reply to Renato Botelho from comment #16)
Yes, I use only the latests version
Comment 19 Renato Botelho freebsd_committer 2016-12-08 19:13:43 UTC
(In reply to Dmitry Ivanov from comment #18)
I cannot see any errors on this build log, it shows for example git-http-fetch being compiled without any errors:

cc -o http-fetch.o -c -MF ./.depend/http-fetch.o.d -MQ http-fetch.o -MMD -MP -isystem/usr/local/include -DLIBICONV_PLUG -O2 -pipe  -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing -I. -I/usr/local/include -DUSE_LIBPCRE -I/usr/local/include -DUSE_CURL_FOR_IMAP_SEND -I/usr/local/include -DUSE_ST_TIMESPEC -pthread -DHAVE_PATHS_H -DHAVE_STRINGS_H -DGMTIME_UNRELIABLE_ERRORS -DHAVE_CLOCK_GETTIME -DHAVE_CLOCK_MONOTONIC -DHAVE_BSD_SYSCTL -DHAVE_GETDELIM -DSHA1_HEADER='<openssl/sha.h>'  -DFREAD_READS_DIRECTORIES -DDIR_HAS_BSD_GROUP_SEMANTICS -DSHELL_PATH='"/bin/sh"' -DPAGER_ENV='"LESS=FRX LV=-c MORE=FRX"'  http-fetch.c
cc -isystem/usr/local/include -DLIBICONV_PLUG -O2 -pipe  -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing -I. -I/usr/local/include -DUSE_LIBPCRE -I/usr/local/include -DUSE_CURL_FOR_IMAP_SEND -I/usr/local/include -DUSE_ST_TIMESPEC -pthread -DHAVE_PATHS_H -DHAVE_STRINGS_H -DGMTIME_UNRELIABLE_ERRORS -DHAVE_CLOCK_GETTIME -DHAVE_CLOCK_MONOTONIC -DHAVE_BSD_SYSCTL -DHAVE_GETDELIM -DSHA1_HEADER='<openssl/sha.h>'  -DFREAD_READS_DIRECTORIES -DDIR_HAS_BSD_GROUP_SEMANTICS -DSHELL_PATH='"/bin/sh"' -DPAGER_ENV='"LESS=FRX LV=-c MORE=FRX"' -o git-http-fetch -L/usr/local/lib -Wl,-rpath,/usr/local/lib -fstack-protector  -L/usr/local/lib http.o http-walker.o http-fetch.o common-main.o \
	-L/usr/local/lib -Wl,-rpath,/usr/local/lib -lcurl -lssl libgit.a xdiff/lib.a  -lpcre -lz -lintl -L/usr/local/lib -Wl,-rpath,/usr/local/lib -lcrypto -pthread

After you finished this 'make' to send me output, can you also run another command and send me output?

# make check-plist >/tmp/output 2>&1

And after that

# find ./work/stage >> /tmp/output
Comment 20 Dmitry Ivanov 2016-12-08 20:21:06 UTC
(In reply to Renato Botelho from comment #19)
Renato, I wrote to comment #3 that the bug is fixed. Something else is necessary?
Comment 21 Renato Botelho freebsd_committer 2016-12-08 20:30:57 UTC
(In reply to Dmitry Ivanov from comment #20)

I lost it and in my head you are still facing it. Sorry! Closing it now