Bug 214249 - audio/openal-soft: Fails to configure with JACK option ON
Summary: audio/openal-soft: Fails to configure with JACK option ON
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason E. Hale
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-05 18:03 UTC by Grzegorz Junka
Modified: 2016-12-07 10:30 UTC (History)
2 users (show)

See Also:
jhale: maintainer-feedback-


Attachments
Poudriere logs (50.08 KB, text/x-log)
2016-11-05 18:03 UTC, Grzegorz Junka
no flags Details
audio/openal-soft, fix JACK option (1.03 KB, patch)
2016-11-14 16:34 UTC, Jason E. Hale
jhale: maintainer-approval? (mva)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Junka 2016-11-05 18:03:29 UTC
Created attachment 176662 [details]
Poudriere logs

Fails to build on 10.3 64-bit.

-- Could NOT find ALSA (missing:  ALSA_LIBRARY ALSA_INCLUDE_DIR) 
-- Found OSS: /usr/include  
-- Could NOT find AudioIO (missing:  AUDIOIO_INCLUDE_DIR) 
-- Found SoundIO: /usr/local/lib/libsndio.so  
-- Could NOT find QSA (missing:  QSA_LIBRARY QSA_INCLUDE_DIR) 
-- Found PortAudio: /usr/local/lib/libportaudio.so  
-- Could NOT find PulseAudio (missing:  PULSEAUDIO_LIBRARY PULSEAUDIO_INCLUDE_DIR) 
-- Found JACK: /usr/local/lib/libjack.so  
CMake Error at CMakeLists.txt:988 (MESSAGE):
  Failed to enabled required JACK backend


-- Configuring incomplete, errors occurred!
See also "/wrkdirs/usr/ports/audio/openal-soft/work/openal-soft-1.17.2/CMakeFiles/CMakeOutput.log".
See also "/wrkdirs/usr/ports/audio/openal-soft/work/openal-soft-1.17.2/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/audio/openal-soft
====>> Cleaning up wrkdir
===>  Cleaning for openal-soft-1.17.2
build of audio/openal-soft ended at Sat Nov  5 14:50:18 UTC 2016
build time: 00:01:03
!!! build failure encountered !!!


Options:

# Options for openal-soft-1.17.2
_OPTIONS_READ=openal-soft-1.17.2
_FILE_COMPLETE_OPTIONS_LIST=CONFIG FLUIDSYNTH JACK PORTAUDIO PULSEAUDIO SNDIO
OPTIONS_FILE_SET+=CONFIG
OPTIONS_FILE_SET+=FLUIDSYNTH
OPTIONS_FILE_SET+=JACK
OPTIONS_FILE_SET+=PORTAUDIO
OPTIONS_FILE_UNSET+=PULSEAUDIO
OPTIONS_FILE_SET+=SNDIO
Comment 1 Jason E. Hale freebsd_committer 2016-11-14 16:34:58 UTC
Created attachment 176997 [details]
audio/openal-soft, fix JACK option

I had the same error.  The problem is with the logic that the JACK option uses.  The attached patch should fix the issue.
Comment 2 Jason E. Hale freebsd_committer 2016-12-07 10:24:12 UTC
Maintainer timeout.
Comment 3 commit-hook freebsd_committer 2016-12-07 10:29:58 UTC
A commit references this bug:

Author: jhale
Date: Wed Dec  7 10:29:30 UTC 2016
New revision: 428046
URL: https://svnweb.freebsd.org/changeset/ports/428046

Log:
  Fix configure when JACK option is enabled

  -- Found JACK: /usr/local/lib/libjack.so
  CMake Error at CMakeLists.txt:988 (MESSAGE):
    Failed to enabled required JACK backend
  -- Configuring incomplete, errors occurred!

  PR:		214249
  Reported by:	Grzegorz Junka <list1@gjunka.com>
  Approved by:	maintainer timeout

Changes:
  head/audio/openal-soft/Makefile