Bug 214274 - net/py-pyzmq fails to find libzmq installed in non-default LOCALBASE
Summary: net/py-pyzmq fails to find libzmq installed in non-default LOCALBASE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Roman Bogorodskiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-06 17:44 UTC by Erick Turnquist
Modified: 2016-11-12 13:09 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (novel)


Attachments
patch (491 bytes, patch)
2016-11-06 17:44 UTC, Erick Turnquist
no flags Details | Diff
update to 16.0.1 (1.39 KB, patch)
2016-11-11 20:33 UTC, Roman Bogorodskiy
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Erick Turnquist 2016-11-06 17:44:00 UTC
Created attachment 176691 [details]
patch

If libzmq is installed in an alternate location (by changing LOCALBASE), py-pyzmq will fail to find it and builds the included zmq instead. The existing Makefile patches setup.cfg, but the behavior must have changed at one point because this no longer seems to have an effect. Instead, we can use --zmq=<path>. The attached patch does this.
Comment 1 Roman Bogorodskiy freebsd_committer 2016-11-11 20:33:41 UTC
Created attachment 176907 [details]
update to 16.0.1

Hi,

Thanks for the patch. I've prepared an update to 16.0.1 and included your change as well. I've attached a patch that does the following:

 - update to 16.0.1
 - use standard test target and add TEST_DEPENDS
 - fix detecting zmq in non-default LOCALBASE

PS It looks like configuration *is* supported through setup.cfg, and it's controlled by value of the "zmq_prefix" option. But configure switch is easier than sedding files. Also, it looks like lib dirs and include dirs are set based on zmq_prefix, so there is no need to define those, so I dropped the part with setup.cfg creation.

Does this look reasonable to you?
Comment 2 Erick Turnquist 2016-11-11 22:33:05 UTC
Hi Roman,

Yep - this makes perfect sense.
Comment 3 commit-hook freebsd_committer 2016-11-12 13:08:53 UTC
A commit references this bug:

Author: novel
Date: Sat Nov 12 13:08:14 UTC 2016
New revision: 425949
URL: https://svnweb.freebsd.org/changeset/ports/425949

Log:
  net/py-pyzmq: update to 16.0.1

   - update to 16.0.1
   - rename regression-test target to do-test and add TEST_DEPENDS
   - fix detecting zmq in non-default LOCALBASE [1]

  PR:		214274 [1]
  Submitted by:	jhujhiti@adjectivism.org [1]

Changes:
  head/net/py-pyzmq/Makefile
  head/net/py-pyzmq/distinfo
Comment 4 Roman Bogorodskiy freebsd_committer 2016-11-12 13:09:30 UTC
Committed, thanks!