Bug 214339 - emulators/virtualbox-ose: could not find or load the Qt platform plugin "xcb"
Summary: emulators/virtualbox-ose: could not find or load the Qt platform plugin "xcb"
Status: Closed DUPLICATE of bug 214340
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-08 23:12 UTC by Petr Fischer
Modified: 2016-11-09 00:09 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Fischer 2016-11-08 23:12:11 UTC
Can't start virtualbox (virtualbox-ose-5.1.8), this error:
------------
Qt FATAL: This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: minimal, offscreen, xcb.

Reinstalling the application may fix this problem.
Abort trap
------------


Maybe some problem with QT5 libraries. My QT libs:
qt5-assistant-5.6.2
qt5-buildtools-5.6.2
qt5-clucene-5.6.2
qt5-concurrent-5.6.2
qt5-core-5.6.2
qt5-dbus-5.6.2
qt5-declarative-5.5.1
qt5-designer-5.6.2
qt5-doc-5.6.2
qt5-examples-5.6.2
qt5-gui-5.6.2
qt5-help-5.6.2
qt5-linguist-5.6.2
qt5-linguisttools-5.6.2
qt5-multimedia-5.6.2
qt5-network-5.6.2
qt5-opengl-5.6.2
qt5-printsupport-5.6.2
qt5-qdoc-5.6.2
qt5-qdoc-data-5.6.2
qt5-qmake-5.6.2
qt5-qml-5.6.2
qt5-quick-5.6.2
qt5-quickcontrols-5.6.2
qt5-script-5.6.2
qt5-sql-5.6.2
qt5-sqldrivers-sqlite3-5.6.2
qt5-svg-5.6.2
qt5-testlib-5.6.2
qt5-uiplugin-5.6.2
qt5-uitools-5.6.2
qt5-webkit-5.6.2
qt5-widgets-5.6.2
qt5-x11extras-5.6.2
qt5-xml-5.6.2
qt5-xmlpatterns-5.6.2
qtkeychain-qt5-0.7.0
Comment 1 otacilio.neto 2016-11-08 23:46:46 UTC
I was getting this same error message here when starting vlc. I have fixed with 
pkg upgrade -f qt5-gui
Comment 2 Petr Fischer 2016-11-09 00:09:07 UTC
You are right! Thanks! Marking as dulicate (and creating new bug in qt5).

*** This bug has been marked as a duplicate of bug 214340 ***