Bug 214340 - devel/qt5: could not find or load the Qt platform plugin "xcb"
Summary: devel/qt5: could not find or load the Qt platform plugin "xcb"
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
: 214339 214474 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-09 00:08 UTC by Petr Fischer
Modified: 2016-11-22 10:28 UTC (History)
2 users (show)

See Also:
rakuco: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Fischer 2016-11-09 00:08:24 UTC
In some apps (like virtualbox or vlc) this erro roccurs when starting app:

------------
Qt FATAL: This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: minimal, offscreen, xcb.

Reinstalling the application may fix this problem.
Abort trap
------------

Manually running "pkg upgrade -f qt5-gui" helps, but it is IMHO a problem/bug.

Look at: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=214339
Comment 1 Petr Fischer 2016-11-09 00:09:07 UTC
*** Bug 214339 has been marked as a duplicate of this bug. ***
Comment 2 Walter Schwarzenfeld freebsd_triage 2016-11-12 23:49:44 UTC
Same problem and solution with ports-mgmt/portrac.
I think there is something missing in the Makefile USE_QT5= gui does not help. Maybe any LIB_BEPENDS?
Comment 3 Tobias C. Berner freebsd_committer 2016-11-13 20:26:28 UTC
*** Bug 214474 has been marked as a duplicate of this bug. ***
Comment 4 rff1917 2016-11-13 20:59:38 UTC
This solution *kind of* worked.

"pkg upgrade" alone was not finding any upgrades since last time and the latest version I always got was "qt5-gui-5.6.2", which causes the problem.

So I had to manually download the "qt5-gui-5.6.2_1.txz" file from the servers and then "pkg add" it.

Even now, running "pkg upgrade -f qt5-gui" wants to downgrade the working 5.6.2_1 version and install version 5.6.2.
Comment 5 Raphael Kubo da Costa freebsd_committer 2016-11-22 10:28:29 UTC
I manually bumped PORTREVISION in qt5-gui in ports r425987 to trigger a rebuild (it's still unclear to me how the xcb part of qt5-gui depends on perl). The repository problems mentioned in comment #4 look unrelated to this specific issue.