Bug 214440 - editors/libreoffice: update failure: No. You make ME a sandwich.
Summary: editors/libreoffice: update failure: No. You make ME a sandwich.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: FreeBSD Office Team
URL:
Keywords:
: 214444 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-12 12:46 UTC by O. Hartmann
Modified: 2016-11-12 14:01 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2016-11-12 12:46:32 UTC
Recent update of port editors/libreoffice from libreoffice-5.0.6_4 to libreoffice-5.2.3 fails due to an unknown error on 12-CURRENT.

See the error below.

This happens on all 12-CURRENT we run and also on poudriere.

[...]
config.status: creating config_host/config_writerperfect.h
configure: WARNING: unrecognized options: --disable-gnome-vfs, --disable-kde, --disable-kdeab, --disable-packagekit, --without-system-npapi-headers, --with-qt-includes, --with-qt-libraries, --with-extra-includes, --with-extra-libs
****************************************************************************

To build, run:
/usr/local/bin/gmake

To view some help, run:
/usr/local/bin/gmake help

After the build has finished, you can immediately run it using:
instdir/program/soffice

If you want to run the smoketest, run:
/usr/local/bin/gmake check

===>  Building for libreoffice-5.2.3
gmake[2]: Entering directory '/usr/ports/editors/libreoffice/work/libreoffice-5.2.3.3'

No. You make ME a sandwich.

gmake[2]: *** [Makefile:58: check-if-root] Error 1
gmake[2]: Leaving directory '/usr/ports/editors/libreoffice/work/libreoffice-5.2.3.3'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/editors/libreoffice
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/libreoffice

===>>> make build failed for editors/libreoffice
===>>> Aborting update

===>>> Update for editors/libreoffice failed
===>>> Aborting update
Comment 1 commit-hook freebsd_committer 2016-11-12 13:26:56 UTC
A commit references this bug:

Author: bapt
Date: Sat Nov 12 13:26:31 UTC 2016
New revision: 425951
URL: https://svnweb.freebsd.org/changeset/ports/425951

Log:
  Allow to bulid as root

  PR:		214440
  Reported by:	O. Hartmann <ohartmann@walstatt.org>

Changes:
  head/editors/libreoffice/files/patch-Makefile.in
Comment 2 Baptiste Daroussin freebsd_committer 2016-11-12 13:27:05 UTC
Fixed thank you
Comment 3 Baptiste Daroussin freebsd_committer 2016-11-12 14:01:54 UTC
*** Bug 214444 has been marked as a duplicate of this bug. ***