Bug 214560 - x11-drivers/xf86-video-vmware: set ONLY_FOR_ARCHS
Summary: x11-drivers/xf86-video-vmware: set ONLY_FOR_ARCHS
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-16 04:09 UTC by Matthew Rezny
Modified: 2017-02-15 10:17 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
correct ARCH restriction for xf86-video-vmware (464 bytes, patch)
2016-11-16 04:09 UTC, Matthew Rezny
no flags Details | Diff
update xf86-video-vmware to 13.2.1 (1.36 KB, patch)
2016-11-21 18:21 UTC, Matthew Rezny
no flags Details | Diff
correct ARCH restriction in xf86-video-vmware (596 bytes, patch)
2017-01-19 22:20 UTC, Matthew Rezny
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Rezny freebsd_committer 2016-11-16 04:09:43 UTC
Created attachment 177048 [details]
correct ARCH restriction for xf86-video-vmware

The recent test run on aarch64 resulted in seemingly random application of either ONLY_FOR_ARCHES or BROKEN_aarch64.

In the case of the video driver for VMware guests, which can only possibly be x86, ONLY_FOR_ARCHES= amd64 i386 is clearly the correct choice.

Ironically, the other xf86-video- ports caught in this run were marked as only for x86, even though they are for PCI cards which surely could have been plugged into non-x86 machines.
Comment 1 Matthew Rezny freebsd_committer 2016-11-21 18:21:01 UTC
Created attachment 177240 [details]
update xf86-video-vmware to 13.2.1

Update xf86-video-vmware to 13.2.1, which is compatible with xorg-server 1.19.

QA: stage-qa and check-orphans are clean on 11 amd64
Comment 2 Baptiste Daroussin freebsd_committer 2017-01-13 22:31:32 UTC

*** This bug has been marked as a duplicate of bug 215005 ***
Comment 3 Matthew Rezny freebsd_committer 2017-01-19 22:17:01 UTC
This PR was not a duplicate considering it was opened first and the other was incomplete.

This PR started with the purpose of correcting the ARCH restriction on this port and then turned into a version update PR when there was a new release. The other PR, which should have been the one marked as duplicate, was opened more than a week after the version update was added to this PR. Since the other PR, which was only a version bump, was committed instead, this PR continues to stand for it's original purpose of correcting the ARCH restriction.
Comment 4 Matthew Rezny freebsd_committer 2017-01-19 22:20:34 UTC
Created attachment 179113 [details]
correct ARCH restriction in xf86-video-vmware

Set ONLY_FOR_ARCHS=i386 amd64 instead of BROKEN_aarch64 and remove USE_XORG items that are redundant in the presence of XORG_CAT=driver.